Author Topic: 04 R1150GSA ABS problem  (Read 499 times)

jambo

  • Beta testers
  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
04 R1150GSA ABS problem
« on: March 29, 2019, 11:17:03 PM »
My 04 R1150GSA had a bad ABS pump and I took one off the shelf (good used) and plugged it in.  It has a high pitched whine all the time and I am getting the following errors from the GS911:

"Integral ABS"
17423: Invalid vehicle coding
     This fault is currently present
17167: Invalid vehicle coding
    This fault is currently present

Everything else looks good, any advice is appreciated!!!

Thank you!!


Jughead

  • Beta testers
  • Hero Member
  • *
  • Posts: 583
  • Karma: +40/-2
    • Dual Sport Motorcycle Clinic
Re: 04 R1150GSA ABS problem
« Reply #1 on: April 01, 2019, 07:27:54 AM »
You have a choice here.

Option 1.  Carefully remove the controller from both pumps and transfer the controller from the original pump to the new pump. (That's the part at the end where your harness plugs in)  All should work fine, obviously depending on what the original fault was.  If the original controller is toast, then obviously that will not work.

Option 2.  Take your bike around to your friendly BMW dealership and get them to reconfigure it.  The ABS pump is "married" to the bike, and what you have done now is gotten rid of the wife and installed a mistress.  You will have to get BMW to give your bike an official divorce, and then your bike MUST marry the new mistress.

I hope that explains it.  Unfortunately that is not something that can be done with the GS911.