Author Topic: Engine won't start after GS-911 HES test on R1150RT  (Read 6390 times)

DougInAmbler

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Engine won't start after GS-911 HES test on R1150RT
« on: July 14, 2015, 03:54:35 PM »
After running the HES test on a bad HES, the engine still wouldn't start after I installed a good HES. This set me back a day or two.
The instructions warn about this, but the warning is unclear and terse.

Here is the warning (v. 1503.2):

"In the subsequent test, the motorcycle is forced into a state where the engine cannot be started. Correct termination of this test subsequently cancels this state. Remember to cycle the ignition after the test."

Here is my suggested clarification:
"In this test the GS-911 puts the Motronic into a state where spark and injection are disabled so that the engine will not start. This state will persist until EITHER the test is successful, OR the Motronic ECU is re-initialized by pulling Fuse F5 for at least 5 minutes."

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Engine won't start after GS-911 HES test on R1150RT
« Reply #1 on: July 15, 2015, 03:33:45 AM »
Are you certain that fuse 5 should be removed or is it merely that the ignition switch needs to be turned off and back on ?

DougInAmbler

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Engine won't start after GS-911 HES test on R1150RT
« Reply #2 on: July 15, 2015, 05:25:58 AM »
Yes.
Key on-off-on: no fuel injection
Pull Fuse 5 for 1 minute: no fuel injection
Pull Fuse 5 for 2 minutes: fuel injection! Bike runs!

This is only for the case where the last HES test did not succeed.

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Engine won't start after GS-911 HES test on R1150RT
« Reply #3 on: July 15, 2015, 09:29:53 AM »
No worries, the reason I asked is there are some urban myths out there re depowering the more modern ECU's which came after the MA2.2 and 2.4 to clear various parameters, you may find that leaving the ignition off for the 2 minutes achieved the same thing.

An update to the instructions though would be worthwhile

DougInAmbler

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Engine won't start after GS-911 HES test on R1150RT
« Reply #4 on: July 15, 2015, 02:52:34 PM »
It would be nice to get clarification from Hexcode whether their warning "remember to cycle the ignition after the test" means simply key off-on or powering down/up the Motronic.

In my case I was baffled for a day and a half observing both clean HES pulses but no fuel injection pulses simultaneously on my oscilloscope. During this time I also observed during cranking that a small spray of starter fluid in the airbox would make the engine run for a few seconds. Fuel pump, pressure and flow tested good. Of course the key was off-on dozens of times. Something was suppressing the fuel injection pulses. I am grateful to Roger 04 RT for suggesting to pull the F5 fuse for a few minutes, which worked like a miracle for me.

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Engine won't start after GS-911 HES test on R1150RT
« Reply #5 on: July 15, 2015, 03:07:26 PM »
Much of what is stated has to be based on what BMW state and there are too many examples of BMW not specifying procedures correctly

To really know which is the procedure I would need to pull out the R1150RT electrical diagrams and then open up an MA 2.2 or 2.4 and I am afraid I dont have one lying round. Now if it was a 650GS I could give you a definitive answer and I have the docs on line for everyone on that model  ;D

It certainly would be nice to clear up the question but I am afraid I have been bitten too many times and prefer to look for myself to confirm these things