Author Topic: Wi-fi GS-911 not connecting to motorcycle  (Read 13772 times)

Alan T. Butler

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
  • Nice day for somethin'
Wi-fi GS-911 not connecting to motorcycle
« on: August 10, 2014, 08:45:12 PM »
Hello: Just received my new wi-fi GS-911 today.  Registered and downloaded the new software to my little Asus netbook per the Quick Start Guide.  This is the same 'puter I use with my original GS-911.  Had a little trouble getting the wi-fi to connect, but after a few tries that worked, although, the first couple times I clicked on "open browser for this device" I got a message stating that there was already a device using that IP address, and did I still want to hijack that address.  I clicked on yes, and everything seemed to work.  I took my 'puter with the new GS-911 connected via the USB cable out into the garage, and connected the GS-911 to the data plug on my K1300S.  I turned on the ignition and selected K1300S, and tried the diagnostic functions.  All I can get is a message saying that either the run switch is set to "off," or the connector is not connected, etc.  No joy. 

I tried it again on my R1200GS Adv and got the same result. 

Is there a special sequence for connecting and operating the new wi-fi GS-911?  Do you have to attach it to the bike before you plug in the USB cable to the computer?  Or what?  Any other tips?

Thank you
 ATB
« Last Edit: August 10, 2014, 08:50:45 PM by Alan T. Butler »

Alan T. Butler

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
  • Nice day for somethin'
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #1 on: August 11, 2014, 12:24:59 AM »
My GS-911 is now communicating with my R1200GS Adv.  I went for a nice ride on my GS after my last post.  Upon returning I felt ready to re-tackle the problem.  I read some other posts, and found that not only do you have to download the GS-911 Wi-Fi utility, but you must have installed the latest GS-911 software, which is to be detected and downloaded with the GS-911 Downloader utility.  I must have missed that part in the Quick Start Guide.  I downloaded everything I could to my Asus Netbook, and tried again.

I was able to get the Wi-Fi to do an autoscan on my GS by using the GS Beta software, with the USB connection between my Asus Netbook and the Wi-Fi GS-911.  That is great, because I think I'll be able to reset the service warning on my pal's R1200GS LC.   

So how does that browser thing work?

Thank you
 ATB

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #2 on: August 11, 2014, 04:32:15 AM »
Think of it as 2 tools like the blutooth unit, a traditional GS911 using the PC software when connected with USB and a WiFi tool when using the software downloaded into the unit

You dont mention registering and downloading software while connected to the PC via WiFi, did you do that step ?

Alan T. Butler

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
  • Nice day for somethin'
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #3 on: August 11, 2014, 05:39:37 AM »
Thank you for your reply.  Yes, I registered the unit, and downloaded updates. 

Seeya
 ATB

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #4 on: August 11, 2014, 06:20:28 AM »
Alan, in the initial WiFi set up when connected to the PC only via WiFi, "Series" menu is grey and cant be selected, once registered the unit goes through an initial download of all the software which has 4 progress bars in it then when finished the "Series" menu is activated, can you confirm that completed ?

The other aspect is when you initially connected via WiFi it indicated there was another device with the same IP No, that suggests you were connected to your home WiFi router when connecting to the GS911 and your home IP No range is the same as the GS911 in Access Point mode

I would normally check the home IP No system, select an IP No which is not in use to use for the GS911 then disconnect the PC from the home network. then connect to the GS911 and set up a network on it using a fixed IP No and connect it into the home network, reconnect the PC into the home network and connect to the GS911 using the fixed IP No

My methods are a little different to most as I work in IT/Telecoms

bdn

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #5 on: August 11, 2014, 07:59:02 AM »
I also have one problem using the beta client when the GS-911 WiFi is connected to the USB port, my OS is Windows 8.1 and it doesn't want to communicate with the GS-911. Must be a problem related to the USB driver that is on Windows 8.1. I'm trying now with a different laptop that has Windows 7, I'll update soon

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #6 on: August 11, 2014, 09:39:11 AM »
No worries, Win8/8.1 is a problem all round away from GS911

Alan T. Butler

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
  • Nice day for somethin'
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #7 on: August 11, 2014, 07:42:03 PM »
More futzing around with the new Wi-Fi GS-911 this morning.  Some discoveries are:

1.  GS-911 beta version 1408.1 came out today, August 11, 2014. 
2.  My new Wi-Fi GS-911 works perfectly on the PC-based program, both with the USB connection and with the Wi-Fi; all you have to do is select "Wi-Fi" or "USB" on the setup screen.
3.  My Wi-Fi GS-911 works almost perfectly with the browser interface on my i-Phone.  For some reason it refuses to check for faults in "motorcycle electronics," but it checks the engine, the ABS, etc. 
4.  My Wi-Fi GS-911 totally refuses to connect, either in W-Fi, or USB, when I try the browser interface on my PC.  I can use the browser interface to make the lights flash on the Wi-Fi GS-911, so that is something, I guess.
5.  Here is the big discovery of the day: I was using the PC-based beta software, connected via USB on my GS, and I went into the service warning reset area.  It asked me for the VIN.  Hey, wait a minute here!  I thought I'd purchased the PRO version!  I clicked on "Help" on the PC-based software, and selected "Upgrade to Professional."  After a quick search online, the screen indicated that now I have the professional version.  This means that if you have the PRO version, you will need to upgrade your Wi-Fi GS-911 yourself, using the PC-based software.

I think I'm pretty well set, but I still don't know why that browser interface is even there on my PC (Asus netbook with Windows 7 Home Premium, Service Pack 1).

Seeya
 ATB

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #8 on: August 12, 2014, 05:19:13 AM »
Alan, well written info and feedback for the Hexcode team there

On point 4, I have yet to try the delights of the PC Browser interface, I will try it here and see what I can find

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #9 on: August 14, 2014, 06:30:51 AM »
Alan

I lowered my standards and loaded up Win7 on one of my notebooks and did a test of the WiFi utility, it was the latest version available from the Hexcode web site yesterday, it passed all the tests I could throw at it, perhaps it is a WIn8/8.1 issue

I had the WiFi unit powered from the USB and it hooked the WiFi unit into my WiFi network , brought up the web browser (Firefox) onto the GS911 WiFi screen etc, did everything it should error free

I work in Telecoms/IT and I am quite impressed (very unusual for me) with the WiFi PC utility, it is the simplest system I have seen

Suggest you open a support ticket over at the help desk if you continue to have difficulties

« Last Edit: August 14, 2014, 06:32:53 AM by WayneC »

Peet Badenhorst

  • Administrator
  • Sr. Member
  • *****
  • Posts: 347
  • Karma: +8/-0
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #10 on: August 19, 2014, 08:55:58 AM »
Hi Alan and Wayne
We can confirm that there is something funny going on with the latest Windows 8.1.
It seems as if Microsoft was a bit too aggressive in their powersaving mode on the USB port.
So it happens sometimes that the software is still communicating to the GS-911wifi over USB and Windows 8.1 will just decide to put it into sleep mode to save power.

Kobus is looking into a workaround which we will incorporate into new versions of the downloader and PC wifi utility.
Regards
Peet

Alan T. Butler

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
  • Nice day for somethin'
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #11 on: August 19, 2014, 11:11:53 PM »
I just downloaded a firmware update for the GS-911 Wi-Fi.  I tried getting my GS-911 to connect to my K1300S via the browser interface.  Still no joy.  I'm using my ASUS netbook with Windows 7 Home Premium (SP-1), which has all the latest PC-based downloads, and all the latest Wi-Fi downloads.

1.  The PC-based interface works perfectly, either on the USB setup or on the Wi-Fi setup, so that is good.
2.  When I try the Wi-Fi browser interface with the ASUS netbook, all I can get is "Error: Attempting to connect to this controller timed out," and the three possible reasons, none of which are true because I just connected via the PC-based interface.  This happens whether I am trying to connect via USB, or via Wi-Fi, clicking on the appropriate "Open browser for this device" button.  I am able to identify (beep) the device, however. 
3.  The GS-911 Wi-Fi app on my iPhone works perfectly with the device.  This is really great!!  Not only does it work with the Wi-Fi in my home network, or in a hotel parking lot, but it also works with the internal Wi-Fi on the device!!  This is HUGE!

So I am left to wonder: what is the point of having the GS-911 Wi-Fi launcher on my ASUS Notebook, other than to check for updates?  Is it designed to be used at all with a PC?  Or not? 

Thank you
 ATB

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1298
  • Karma: +27/-1
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #12 on: August 20, 2014, 05:02:01 AM »
Alan, I am wondering if there is a firewall setting problem with your ASUS, what Antivirus software do you have and does it have a firewall components ?

Try turning off AV and firewall to see if the problem continues

Peet Badenhorst

  • Administrator
  • Sr. Member
  • *****
  • Posts: 347
  • Karma: +8/-0
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #13 on: August 20, 2014, 02:01:26 PM »
Alan
What version of Internet Explorer is the ASUS running?

Please  try the following and see if that makes a difference:
Set Internet options->Browsing history->Settings->Temporary Files->Every time I visit page

Regards
Peet

Alan T. Butler

  • Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
  • Nice day for somethin'
Re: Wi-fi GS-911 not connecting to motorcycle
« Reply #14 on: August 20, 2014, 06:38:53 PM »
Peet: Thank you!  IT WORKS!!  I did not have to shut off my McAfee firewall.  All I had to do was to make the change to IE that you recommended in your last post.  That was all.  Amazing.  I just got done checking my R1200GSAdv, and then the K1300S.  I even fired up the K1300S just to see the realtime numbers change. 

The Autoscan function is greyed out, but I am guessing that we'll get that in an update.  Oh yeah - I have IE9 on the ASUS netbook.  Thanks again.

Seeya
 ATB