Author Topic: CAN-bus Timeout: no communication with KOMBI (Instrument Cluster) control unit  (Read 235 times)

fletch

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Hello All. I have an intermittent problem (the worst kind). BMW 2007 R1200R about 110,000Km. On a cool morning, the problem started as no power to the instruments. But bike would start and run as usual. After 10 minutes or so, things would warm up and suddenly all normal. Problem now is bike has no power at all. Like a dead battery. But as the day warms up, all back to normal.

A scan says fault code 10218 or 54105. The CAN-bus Timeout: no communication with KOMBI control unit.

I have checked battery voltage - about 12.7V. I have cleaned up battery terminals, and three earth points on the engine. I opened the big connectors on the (? what are they called) two computer type things under the tank and sprayed with contact cleaner. I fear I now need to look for something more specific.

Any ideas please?

Cheers

Fletch in Western Australia

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1289
  • Karma: +27/-1
Have seen similar issues caused by failing power rail capacitor in the dash, take a look at Advrider Oz regional forum & there are 2 threads about it

fletch

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Thanks WayneC. Read those posts and found a couple of others along the same lines. This problem is frustrating more than just me. Weird that it is intermittent and ambient temperature related.

Where can I get such a repair done? Any recommendations please. I am near Perth in Western Australia.

Cheers Fletch

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1289
  • Karma: +27/-1
I have een doing repairs for the 650GS owners for years & was convinced to look at the F/R twin dashes by one of the independent workshops here on the east coast as the fault is basically the same degradation of the power supply electrolytic capacitor, any decent electronics repairer should be able to do it but re aligning the needles is different on your style dash, one of your style dashes set to me was intermittent & would take time to start operating mainly in cold weather, it was simply the time taken for the capacitor to warm up & store enough energy to power the dash properly

At worst you can contact me via the contact form on the 650GS web site http://www.f650gs.crossroadz.com.au/AboutGS.html

Jughead

  • Beta testers
  • Hero Member
  • *
  • Posts: 711
  • Karma: +46/-3
    • Dual Sport Motorcycle Clinic
Check the switch module below the ignition key.  Easiest check is just to unplug it and short out the 2 points on the harness plug.  The switch module is prone to corrosion.

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1289
  • Karma: +27/-1
Fletch, well worth checking the connector Jughead has referred to he sees more bikes than I & is always worth listening to, it is as per my email response to you last night that there are other issues which could cause the fault, if you have not seen my email check your junk folder
« Last Edit: May 17, 2022, 04:34:32 AM by WayneC »