Author Topic: Help with Fault. Starter does not run.  (Read 298 times)

fotodadi

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +0/-0
Help with Fault. Starter does not run.
« on: August 24, 2020, 04:07:17 PM »
Hi.

Any help will be appreciated to point me in the right direction.

Symptoms: Starter is not running. Engine does not start even when pushed to start. No spark at plug when starter is operated manually.

Scan shows the following fault:

CD845F CAN, node A, Fahrzeug-CAN, BusOff fault. The fault is currently present.

ECU and all where taken from a K 1600 GTL Exclusive (K48) with 41449km. Is there anyway I can get the ECU to stand alone and run the engine? I understand this fault means the CAN bus is broken somewhere.

HELP!
« Last Edit: August 24, 2020, 04:17:58 PM by fotodadi »

Jughead

  • Beta testers
  • Hero Member
  • *
  • Posts: 661
  • Karma: +42/-2
    • Dual Sport Motorcycle Clinic
Re: Help with Fault. Starter does not run.
« Reply #1 on: August 25, 2020, 07:19:02 AM »
Hi Fotodadi

1. What do you mean when you say "ECU and all where taken from a K 1600 GTL Exclusive (K48) with 41449km."?  Have you transplanted another bike's ECU onto your bike?  If so, did you transfer the locks and keys as well?

2. What do you mean when you say "No spark at plug when starter is operated manually."?  How do you operate the starter "manually"?

fotodadi

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +0/-0
Re: Help with Fault. Starter does not run.
« Reply #2 on: August 25, 2020, 10:29:00 AM »
Hi Fotodadi

1. What do you mean when you say "ECU and all where taken from a K 1600 GTL Exclusive (K48) with 41449km."?  Have you transplanted another bike's ECU onto your bike?  If so, did you transfer the locks and keys as well?

2. What do you mean when you say "No spark at plug when starter is operated manually."?  How do you operate the starter "manually"?

So, following the total write off of my K1600 GTL Exclusive, I am undertaking a K1600 powered Go-cart project. I do have all the modules, sensors, keyless fobs, cluster etc. Now since the bike was totally and well damaged, I want to start the engine on a bench before I proceed to build the go-cart.

To operate the starter manually, I have to provided a -ve and +ve to the starter relay. This gets the starter to run and the engine turns over. That's what I mean by starting it manually.

I have read and found out that I could get an aftermarket ECU to run my engine, but I feel it would be such an extra expense doing that when I have all the components from my bike.

Any help on how I can get this running?

StephanT

  • Administrator
  • Sr. Member
  • *****
  • Posts: 428
  • Karma: +20/-2
    • HEXcode
Re: Help with Fault. Starter does not run.
« Reply #3 on: August 26, 2020, 06:09:32 PM »
hi Fotodadi, 

pls post a full autoscan

also post a full list (log or screenshots) of real-time values for the engine controller with :
 - ignition ON
 - KILL switch in the RUN position

fotodadi

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +0/-0
Re: Help with Fault. Starter does not run.
« Reply #4 on: August 26, 2020, 07:38:29 PM »
hi Fotodadi, 

pls post a full autoscan

also post a full list (log or screenshots) of real-time values for the engine controller with :
 - ignition ON
 - KILL switch in the RUN position

Great. Thank you. Will set up and do tomorrow.

fotodadi

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +0/-0
Re: Help with Fault. Starter does not run.
« Reply #5 on: August 27, 2020, 10:58:56 AM »
So we set it all up this morning and it started right up 
. Seems we might have had a loose connection somewhere even though we went through every single module.

Thank you so much for the support. We will now separate the non-essential modules/wiring so we have only those that run the engine.  8) 8)