Author Topic: Buffer Index Out of Range  (Read 9749 times)

aggieengineer

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Buffer Index Out of Range
« on: December 18, 2019, 11:55:32 PM »
I installed the new firmware today, and connected the GS-911 to my K1600GT. As always, it prompts for an AutoScan.
When I perform that function, I get an error message:

Buffer Index Out of Range

I've tried two different laptop PCs, and used both USB and wireless connection as a test.
It is possible to scan for fault codes in the individual systems.

Any idea what is interfering with AutoScan?

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Buffer Index Out of Range
« Reply #1 on: December 19, 2019, 03:12:56 AM »
I would suggest lodging a support ticket with Hexcode, https://www.hexcode.co.za/contact-us-1

Out of interest what firmware revision does the "about" screen show

aggieengineer

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #2 on: December 19, 2019, 03:31:46 AM »
The version is 1912.1, datapack version 14.50.
I'll take your suggestion and create a support ticket.

Thank you.

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Buffer Index Out of Range
« Reply #3 on: December 19, 2019, 06:38:44 AM »
The version is 1912.1, datapack version 14.50.
I'll take your suggestion and create a support ticket.

Thank you.

OK you are referring to the new PC App not the GS911 firmware used in stand alone mode with web browser & cloud, definitely lodge a ticket

Mornay

  • Beta testers
  • Full Member
  • *
  • Posts: 155
  • Karma: +6/-0
Re: Buffer Index Out of Range
« Reply #4 on: December 19, 2019, 09:46:20 AM »
Hi all,

Just keeping this post up to date. I'm in contact with the OP via our helpdesk.

Regards,
Mornay

aggieengineer

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #5 on: December 19, 2019, 02:50:45 PM »
I would suggest lodging a support ticket with Hexcode, https://www.hexcode.co.za/contact-us-1

Out of interest what firmware revision does the "about" screen show

The firmware version is 0.254-0.175-0.152

Thanks for the interest. The Hexcode folks will be on vacation for a couple of weeks, as I hope many of us are.
I'll report again in January. Usually a bit cold to ride around here in Texas anyway.

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Buffer Index Out of Range
« Reply #6 on: December 19, 2019, 03:11:25 PM »

The firmware version is 0.254-0.175-0.152

Thanks for the interest. The Hexcode folks will be on vacation for a couple of weeks, as I hope many of us are.
I'll report again in January. Usually a bit cold to ride around here in Texas anyway.

Enjoy xmas, I am sure Hexcode will resolve any problem quickly

The opposite here in Sydney today way too hot (40c) & air quality far too low to ride, the car with air con on & recycle air setting was the way to go

aggieengineer

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #7 on: December 19, 2019, 06:38:54 PM »
Here is one more clue for  the Hexcode engineers.

The AutoScan works normally with my 2008 R1200RT. Still getting the same message on the K1600.

meperez63

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #8 on: December 28, 2019, 08:40:15 PM »
I also am having the same issue. Updated the software to the latest version and keep on getting the same message.

Sent and email to the help desk

2018 R1200GSA K51

aggieengineer

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #9 on: December 28, 2019, 09:28:42 PM »
I've been receiving regular messages from the GS-911 guys, despite it being a holiday. I suspect they will have it figured out soon, so I'm not worried. The information provided in an AutoScan can be retrieved if necessary by scanning the systems individually.

kaileybutt

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #10 on: December 31, 2019, 07:26:50 PM »
2018 RT w/current firmware; also getting the error "buffer index out of range" :(

wjrich

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #11 on: January 02, 2020, 12:06:37 AM »
2017 GS; WiFi GS-911 version with the oblong OBD plug

Just received my 911 yesterday, downloaded the software on my Windows PC, registered the unit then hooked it up to my bike via USB cable.

I was prompted for an Auto Scan which I did. Scan showed an old non-recurring fault with my ignition lock system. I cleared the fault, scanned again and had no faults showing.

I then registered my VIN (it's an Enthusiast version). Shut everything down and reconnected to try again- no problem, system worked as expected. Since the 911 is new to me, I ran through some of the service checks- exhaust flapper, fan, etc and was thrilled with how easy everything seemed to work, put everything away and figured I would tackle the wireless setup today.

Hooked the 911 back up to my bike.this afternoon and the first thing it said was "New Vehicle Detected. Perform and AutoScan for a status overview". I thought that was odd since I had registered the VIN yesterday, but went ahead and ran an AutoScan. The green progress bar seemed to be moving along normally, but went it got to the end, I got a "Buffer index out of range" message. I tried going into individual service tasks and received the same buffer message.

I did manage to get 1 AutoScan via my iPhone which showed my VIN and other registration information but that was after a couple of different attempts.

Before I started all of this today, I did check for updates and there was one that I downloaded.

I will be contacting the help desk, but this is really disappointing for my first experience with this device.

Seems I'm not the only one out there with this issue. Any quick fix advice?

2017 GS

aggieengineer

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #12 on: January 02, 2020, 01:14:07 AM »
I would not worry. I've been doing some troubleshooting with the Hexcode folks as time allows. Remember, it's the holiday season. This glitch occurs only when not using the cloud function, hence your results. They'll get it figured out. The GS-911 is a fantastic aid to BMW owners. Don't let one small software problem color your opinion too much. I have found the Hexcode staff to be very responsive, and justifiably proud of their device. I have no doubt that this will be a small and temporary inconvenience.
« Last Edit: January 02, 2020, 01:31:39 AM by aggieengineer »

wjrich

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: Buffer Index Out of Range
« Reply #13 on: January 02, 2020, 02:28:22 AM »
I would not worry. I've been doing some troubleshooting with the Hexcode folks as time allows. Remember, it's the holiday season. This glitch occurs only when not using the cloud function, hence your results. They'll get it figured out. The GS-911 is a fantastic aid to BMW owners. Don't let one small software problem color your opinion too much. I have found the Hexcode staff to be very responsive, and justifiably proud of their device. I have no doubt that this will be a small and temporary inconvenience.
Good to know and I hope a fix is forthcoming. It's tough to look at a tool positively after spending $400 and having it break/malfunction on the 2nd use.
2017 GS

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Buffer Index Out of Range
« Reply #14 on: January 02, 2020, 04:29:58 AM »
Good to know and I hope a fix is forthcoming. It's tough to look at a tool positively after spending $400 and having it break/malfunction on the 2nd use.
Unfortunately you have purchased & set up just after a new set of firmware & PC App was released, the issue you have affects only a small No of models & it is unusual for an issue to slip through the release process, I am sure Hexcode will resolve it, they support their product very well