Author Topic: GS-911 pins don't mate to R1150RT  (Read 3484 times)

roebling

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
GS-911 pins don't mate to R1150RT
« on: March 11, 2016, 07:22:13 PM »
Hi, my new GS-911 doesn't see the iABS controller on my '04 R1150RT-P. Looking at the pins on the GS-911, I noticed that two of the five don't match up with two of the five on the bike's data plug. Could that be why the GS-911 doesn't see the iABS controller?

schuppi

  • Sr. Member
  • ****
  • Posts: 483
  • Karma: +20/-0
Re: GS-911 pins don't mate to R1150RT
« Reply #1 on: March 11, 2016, 11:22:14 PM »
Hello
That's right, because the diagnostic session for the 1150 don't need the remaining connectors.
Diagnostic runs by K-line, only 3 cables required.
The other connectors are for newer bikes like r1200 '04 +.

Think there will be a faulty power supply for this ECU. Please check fuses, relay and wiring.

Hope this helps
Schönen Tag
Wolfgang
                                       talk less, drive more

roebling

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: GS-911 pins don't mate to R1150RT
« Reply #2 on: March 14, 2016, 12:42:16 AM »
Thanks for the reply. Checked all fuses, all OK. So I bought a used ABS module off eBay, advertised as good. Put in the eBay module, filled it & bled lines. Good news/bad news: GS-911 now sees ABS module, that's the good. But GS-911 now reports "17419: Rear ABS motor defective." Also, "17182: Pressure in front wheel circuit to high" (sic). A third fault, "17911: Defective rear light" went away when I replaced the factory 10 watt bulb over the license tag with a 21 watt bulb, for some reason. The brake light had a working & properly spec'd 21 watt bulb already.
I'm giving up on ABS until/unless Module Masters gets their rebuilding operation sorted out.
Thanks again schuppi & everybody in the forum community here