Author Topic: K1200S will not recognize ESA calibration  (Read 10483 times)

ricknut

  • Beta testers
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
K1200S will not recognize ESA calibration
« on: June 02, 2013, 04:41:01 PM »
K1200S will not recognize ESA calibration.

see attached

No ESA can be calibrated is fitted for this motorcycle.

This might be one of the aftermarket ESA manufactures. ESA is on this bike and does work.

kobus

  • Administrator
  • Full Member
  • *****
  • Posts: 180
  • Karma: +11/-1
    • GS-911
Re: K1200S will not recognize ESA calibration
« Reply #1 on: June 03, 2013, 10:19:35 AM »
Hi Rick

I don't see the AutoScan attached?
---
R1200GS Adventure (personal weapon of choice)
... and then the company fleet.

kobus

  • Administrator
  • Full Member
  • *****
  • Posts: 180
  • Karma: +11/-1
    • GS-911
Re: K1200S will not recognize ESA calibration
« Reply #2 on: June 03, 2013, 10:24:31 AM »
Looking at an AutoScan from another thread (I assume it is the same bike):

Configuration   
   Speed sensor manufacturer is Beru   
   Speed sensor type is DF11   
   ABS fitted   
   DWA fitted   
   Heated grips   
   Outside temperature sensor   
   Rear bulb replacement   
   Film type fuel sensor   
   Manual low beam off switch   
   Increased power output for high beam   
   Storage of temperature indication when engine hot   

It is  clear the the ZFE does not have an ESA with Hall sensor fitted (or at least does not know about it).
You say this might be an after market ESA - do you have any more info?

---
R1200GS Adventure (personal weapon of choice)
... and then the company fleet.

ricknut

  • Beta testers
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: K1200S will not recognize ESA calibration
« Reply #3 on: June 03, 2013, 02:51:47 PM »
Yes, this bike does have the ESA. I heard the motors come on Friday night.  Maybe I am confused but bike does have an ESA button and lcd display does have normal, comfort and sport when I press esa button.

When I bought this bike used three years ago, the esa motor wires were for some reason clipped and I had an error code. I repaired wires and esa seems to work.  Not sure why the controller will not complete ESA calibration test.

error message. 

"No ESA can be calibrated is fitted for this motorcycle."

You say this might be an after market ESA - do you have any more info?
BTW, About two years ago, the alarm test would not recognize controller. Stephan notice this alarm was an after market. We got this problem resolved and alarm test works. I do not have any more info. 

I tried the other ZFE tests from new beta software and all seems fine but horn test. Horn test would turn on but not turn off so I had to turn off ignition switch.

BTW, Where you able to look at the logs? I did send a few logs out on Saturday.

I will try another laptop with beta software.

I could give you the ZFE S/N:

StephanT

  • Administrator
  • Sr. Member
  • *****
  • Posts: 398
  • Karma: +17/-2
    • HEXcode
Re: K1200S will not recognize ESA calibration
« Reply #4 on: June 04, 2013, 09:46:36 PM »
Kobus,

seems like we could use Rick on the Beta Testers group - what say you?  :D

best,
Stephan

ricknut

  • Beta testers
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: K1200S will not recognize ESA calibration
« Reply #5 on: June 04, 2013, 10:17:11 PM »
Let me know if i can help.  :)

kobus

  • Administrator
  • Full Member
  • *****
  • Posts: 180
  • Karma: +11/-1
    • GS-911
Re: K1200S will not recognize ESA calibration
« Reply #6 on: June 05, 2013, 09:14:27 AM »
Yes, this bike does have the ESA. I heard the motors come on Friday night.  Maybe I am confused but bike does have an ESA button and lcd display does have normal, comfort and sport when I press esa button.

When I bought this bike used three years ago, the esa motor wires were for some reason clipped and I had an error code. I repaired wires and esa seems to work.  Not sure why the controller will not complete ESA calibration test.

The calibration test is only for ESA with Hall sensors. Your ZFE configuration says you do not have this type of ESA and thus it cannot be calibrated.
Some earlier ESA versions has resistive sensors and cannot be calibrated.

I tried the other ZFE tests from new beta software and all seems fine but horn test. Horn test would turn on but not turn off so I had to turn off ignition switch.
Do you have an aftermarket horn fitted? If there is an error on the output it usually stays on - had the same issue during Beta testing with a fuel pump controller which caused the fuel pump to stay on.
---
R1200GS Adventure (personal weapon of choice)
... and then the company fleet.

rapala50

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
Re: K1200S will not recognize ESA calibration
« Reply #7 on: June 29, 2013, 12:59:29 PM »
I have a 2008 R1200rt with ESA and also had an error message saying No ESA can be calibrated is fitted for this motorcycle , I then ran a autoscan and the ZFE did not show the ESA , is this something Hexcode will be able to correct on bike that have different types of ZFE ?



 
VIN: WB10388088ZT12579
Mileage: 37417.0 km
Factory I-Level: K024-07-10-500
Actual I-Level: K024-09-02-500

--------------------------------------------------------------------------------
BMS-KP2BMS type: BMS-KP2
Part No.: 7722565
Hardware Index: 10
Coding Index: 2
Manufacturer: Bosch
Manufacturing Date: 2007-09-02
HWOE No.: 25923656
MCV: 0.6.0
FSV: 0.77.35
OSV: 2.3.1
Factory I-Level: K024-07-10-500
Actual I-Level: K024-09-02-500
VIN model year: 2008




No fault codes found

--------------------------------------------------------------------------------
ZFE-HighZFE type: ZFE-High
Factory I-Level: K024-07-10-500
Actual I-Level: K024-09-02-500
Part No.: 7718037
Hardware Index: 3
Coding Index: 9
Manufacturing Date(YY/MM/DD): 2004-04-15
MCV: 0.6.0
FSV: 2.2.1
OSV: 3.3.0
Manufacturer: Loewe Lear
HWOE No.: 25912776
 
Configuration 
   Speed sensor manufacturer is Bosch 
   Speed sensor type is DF11 
   ABS fitted 
   Heated grips 
   Heated seat driver 
   Heated seat passenger 
   Outside temperature sensor 
   Brake light switch status over CAN 
   Film type fuel sensor 
   Manual low beam off switch 
   Storage of temperature indication when engine hot 
   Electronic windscreen present 
   Cruise control present 




No fault codes found

--------------------------------------------------------------------------------
Integral ABS 2 - CANPart No.: 7711978
HW Version No.: C1
Coding Index: 0
Manufacturing Date: 2007-09-17
HWOE No.: 25700208
Manufacturer: Continental Teves
MCV: 0.6.0
FSV: 2.2.0
OSV: 3.3.0
Free programming slots: 1
Serial No.: 679H0035A
Hardware No.: 07682002
Hardware star No.: 07711978




No fault codes found

--------------------------------------------------------------------------------
CAN-Kombi H/LCluster type: CAN-Kombi H/L
Part No.: 7718209
Hardware Index: C6
Coding Index: 4
Manufacturer: Siemens VDO Automotive
Manufacturing Date: 2007-02-08
HWOE No.: 25913384
MCV: 0.6.0
FSV: 1.7.1
OSV: 3.3.10
Factory I-Level: K024-07-10-500
Actual I-Level: K024-09-02-500
Assembly No.: 07718210




1 fault codes found:

37641 Electrical System (KL30) under-voltage
The fault is not present now.
 
« Last Edit: June 29, 2013, 01:05:20 PM by rapala50 »
The Purpose of the ride is to get from one place to another, mentally speaking of course !!!

StephanT

  • Administrator
  • Sr. Member
  • *****
  • Posts: 398
  • Karma: +17/-2
    • HEXcode
Re: K1200S will not recognize ESA calibration
« Reply #8 on: June 29, 2013, 05:57:12 PM »
Rapala,

the GS-911 does not say that you do not have ESA... it says that you do not have an ESA with a HALL sensor, and thus cannot be calibrated...

there are 2 ways to measure the ESA position, the first units that were released, used a potentiometer to measure the position. The next versions (Still ESA 1) used a HALL sensor... And the ZFE configuration then has a bit that states whether your ESA is equipped with a Hall sensor.. hence "ESA with Hall sensor fitted"

If you can, what I would like would be posting some pictures of your ESA, especially the electrical connectors on the front and rear struts...

thanks
Stephan

rapala50

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
Re: K1200S will not recognize ESA calibration
« Reply #9 on: July 01, 2013, 04:16:19 AM »
No where on this Autoscan does it say I have ESA, or that I don't ESA with Hall sensor, here is a picture of my ESA switch, to much Tupperware to remove for a picture if the connectors, sorry....
The Purpose of the ride is to get from one place to another, mentally speaking of course !!!

StephanT

  • Administrator
  • Sr. Member
  • *****
  • Posts: 398
  • Karma: +17/-2
    • HEXcode
Re: K1200S will not recognize ESA calibration
« Reply #10 on: July 01, 2013, 01:43:45 PM »
ok, let me be clear about this...

there is NO WAY for us to tell whether you have ESA...  all we can see is if the "ESA with HALL sensor" bit is set in the ZFE configuration...

whether your bike is equipped with ESA, whether with HALL or potentiometer, can only be seen from the Vehicle Order, which we cannot decrypt at this point... which is why we are NOT telling you in an Autoscan or any other place that you do or do NOT have ESA...

We can however tell you if you have ESA with a HALL sensor... and we also do pop up an error warning if you want to do ESA calibration but do NOT have a HALL-type ESA...

best,
Stephan



bikecrazy5

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +1/-0
Re: K1200S will not recognize ESA calibration
« Reply #11 on: July 01, 2013, 09:34:11 PM »
hi guys

first things first, before trying any further calibration.
On the k models have a look by the front spring strut, there is a cable running to the strut, follow that cable towards the control units.There is a tie strap[cable tie] at the parra lever, approximately 10 cm from the strut bolt, the cable loves breaking off there and if it is broken no calibration will be able to be done and does not always store a fault code.

Now to check that cable you must: make a small slice in the cable casing where the cable tie was and give each wire a tug individually.

What tends to happen is that with the movement of the strut it breaks the wires inside the casings.

so I recommend checking that out first.
once repaired, try calibrating again.
let us know how it goes.

regards

StephanT

  • Administrator
  • Sr. Member
  • *****
  • Posts: 398
  • Karma: +17/-2
    • HEXcode
Re: K1200S will not recognize ESA calibration
« Reply #12 on: July 03, 2013, 12:37:02 PM »
thanks for the post, however this is not the issue. rapala posted that although he has ESA, we do NOT show that in the ZFE calibration and when he then tries a calibration, the GS-911 tells him that there is NO "ESA with Hall sensor". As I explained all we can tell is whether there is an "ESA with HALL sensor", and if there is not one, that does NOT mean that there is no ESA with potentiometer..

 there is just no way for us to tell from the ZFE data (only place we know of, that shows ESA in general is in the Vehicle Order - which we cannot read at this point)


DeusExMaxima

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: K1200S will not recognize ESA calibration
« Reply #13 on: June 24, 2016, 12:32:18 AM »
I have a 2008 k1200s, non ESA. Can ESA be retrofitted by installing ESA shocks and ESA button and then activated using gs911?