Author Topic: ews fault gs911 won't read or accept vin vin  (Read 2945 times)

harmonzo1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
ews fault gs911 won't read or accept vin vin
« on: March 28, 2021, 04:51:08 AM »
hi all - first time post. i have 2010 r1200rt that won't start due to a supposed ews fault. i tried using my gs911 for the first time and it won't read my bikes VIN or allow me to enter it manually. i can see that the gs911 is communicating with the software by seeing the light at the bottom of the computer screen blinking green and red.

for this ews fault hexcode recommend to do a scan with the gs911 because the ews fault may actually be some other problem.

the gs 911 software tells me that i need to
1 to turn on ignition
2 select neutral on the gearshift
3 kill switch in 'on' position

i've done all that but it doesn't solve the problem.  any suggestions ?

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #1 on: March 29, 2021, 02:36:14 AM »
Firstly is the GS911 a yellow or WiFi version ?, secondly what happens if you click OK to the Ignition on dialogue ?

harmonzo1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: ews fault gs911 won't read or accept vin vin
« Reply #2 on: March 30, 2021, 05:59:46 AM »
hi wayne c -thanx for your message

i'm using the latest red  wifi unit with odb port and the round adaptor for my 2010 bike. 

i used the usb option to keep things simple.

the only functions that the gs911 will allow me to do is an autoscan which has missing information. (attached)

the sotware doesn't recognise that the ignition is 'on' and the bike is in neutral. (Faulty or intermittent  neutral switch or side stand

switch ?)

  pressing the yes button does nothing- message reappears. stuck in a loop

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #3 on: March 30, 2021, 07:10:46 AM »
OK, understood re model of GS911, I see the GS911 WiFi info in the autoscan, there is one bug fix for it available if you do a firmware update, the PC software is up to date so that should be OK, did you register the GS911 ?. You can do the firmware update with th GS911 WiFi utility if you installed it , it can also assist you configuring the GS911 into your home WiFi net for firmware updates & access to maintenance functionality via web browser

In terms of the bike it is clearly communicating with the bike to get the info & being a 2010 model I would not expect a failure to recognise a VIN, I can see the primary K-Line is operational with 3 ECU's (BMSKP. Dash, ZFE) showing but the 2nd is not communicating with the ABS

Assuming it is a K26, the GS911 interfaces to BMSKP ECU & the interface is 6 wire with V-Batt & V-Ign on the 10 pin round socket so ensure no blown fuse on V-Ign, Comms is dual K-Line with separate BMSKP & ABS diagnostics connections

It is possible for BMSKP to corrupt the VIN stored in it but look at the simple things first, I would lodge a ticket with Hexcode, they would be able to look at logs & see what tech details that shows re the comms https://www.hexcode.co.za/contact-us-1

« Last Edit: March 30, 2021, 07:13:40 AM by WayneC »

harmonzo1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: ews fault gs911 won't read or accept vin vin
« Reply #4 on: March 30, 2021, 10:44:27 AM »
hi wayne

the gs911 is registered. i'll follow your advice and try hexcode. thanx again

Wilco

  • Administrator
  • Jr. Member
  • *****
  • Posts: 87
  • Karma: +4/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #5 on: March 30, 2021, 03:56:55 PM »
Faulty or intermittent  neutral switch or side stand switch ?

You can always check realtime values to rule these out.

harmonzo1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: ews fault gs911 won't read or accept vin vin
« Reply #6 on: April 03, 2021, 04:22:24 AM »
thanx wilco - i read the hexcode 'how to' and i can't workout how to generate the data. also the live graph url  is dead.

i also tried using the gs911 wifi app to see if that would play nice but i got the same results as using usb to computer. (i thought there maybe an issue with a usb driver)

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #7 on: April 03, 2021, 04:42:49 AM »
Harmonzo1

Where are you located ?, I noticed the Vehicle Order is for an Oz bike, would you be in Sydney by any chance ?
« Last Edit: April 03, 2021, 04:44:45 AM by WayneC »

harmonzo1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: ews fault gs911 won't read or accept vin vin
« Reply #8 on: April 03, 2021, 05:43:48 AM »
near grafton nsw

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #9 on: April 03, 2021, 06:18:25 AM »
near grafton nsw

Ah well it was worth a thought, I am in Sydney & thought if you were near by & were wanting to look at it over the Easter break we may have been able to get together, Grafton is a little out of th way but I come from up that way at Macksville so rather like the Nth Coast
You would be welcome to ring/email if you wanted some further assistance over the break, you can find a contact form on the 650gs web site, I wont put email or phone No on an open forum  http://www.f650gs.crossroadz.com.au/ look in the about section for the form

harmonzo1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: ews fault gs911 won't read or accept vin vin
« Reply #10 on: April 05, 2021, 02:55:19 AM »
hi wayne - i've left a message at crossroadz

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #11 on: April 05, 2021, 05:53:15 AM »
hi wayne - i've left a message at crossroadz

Responded to your message, check your inbox or junk email folder

Wilco

  • Administrator
  • Jr. Member
  • *****
  • Posts: 87
  • Karma: +4/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #12 on: April 06, 2021, 02:36:58 PM »
Scanned your support ticket.
Looks like comms cannot be initiated with any of the controllers. This is highly unusual if actually caused by faults on the EWS, as the behaviour is similar to controllers simply not being powered.
If it wasn't for the partial autsocan being returned I'd have said the GS-911 might as well be talking to a brick...

harmonzo1

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: ews fault gs911 won't read or accept vin vin
« Reply #13 on: August 04, 2021, 12:59:53 PM »
i delivered my dead bike to the bmw dealer in mid may and i got the working bike back last week. (520kms round trip)

long story short  - the bmsk module had failed.

i hope to retry my gs911 in the next few days.

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: ews fault gs911 won't read or accept vin vin
« Reply #14 on: August 04, 2021, 03:03:29 PM »
i delivered my dead bike to the bmw dealer in mid may and i got the working bike back last week. (520kms round trip)

long story short  - the bmsk module had failed.

i hope to retry my gs911 in the next few days.

Good to hear it is resolved, sounds like EWS components failed or corrupted, I have a BMS-KP here which autoscans OK but has an EWS fault