Author Topic: Saving VIN to GS 911wifi  (Read 2861 times)

2UpAdventures

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Saving VIN to GS 911wifi
« on: August 23, 2020, 10:52:04 PM »
Hi All & TIA.. I am trying to use the GS911wifi to reset my service intervals and it keeps asking to log the VIN however it seems it is stuck there. It is reading codes, and all so I know the connection is good however it freezes (iPhone) or crashes (desktop software) when I go to save my VIN. Any ideas where I am going wrong?

R1250GS
No VINs registered to the device
Purchased second hand, never used, no VINs saved
GS911wifi registered in my name

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Saving VIN to GS 911wifi
« Reply #1 on: August 24, 2020, 04:16:47 AM »
Welcome to the forum,

When you purchased the GS911 WiFi, did you take a look through the Web UI menu's & update the firmware ?, seems odd no VIN's registered  it

I assume you downloaded the Download Utility to get the PC App & the WiFi Utility, what version is the PC App ?



2UpAdventures

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Saving VIN to GS 911wifi
« Reply #2 on: August 25, 2020, 03:03:14 PM »
Hey, thanks!

Yes updated the software this week, can use via my iPhone and laptop.. I can scan, read codes from when I dropped the bike and all that great jazz. When it come to clearing codes or updating the service reminder it asks me to register the VIN of my bike, then the software crashes. Very weird, very frustrating..


Sent from my iPhone using Tapatalk

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Saving VIN to GS 911wifi
« Reply #3 on: August 25, 2020, 03:26:36 PM »
OK, but you did not specify updating firmware of the GS911 as well as the software however it does sound weird, lodge a help desk support ticket

https://www.hexcode.co.za/contact-us-1

2UpAdventures

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Saving VIN to GS 911wifi
« Reply #4 on: August 25, 2020, 03:28:13 PM »
Ok, will do. Thanks for your help


Sent from my iPhone using Tapatalk

ATCguy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Saving VIN to GS 911wifi
« Reply #5 on: March 20, 2021, 12:50:19 AM »
Hello... I am having the same issue as the OP during my initial use & setup of the tool on my 2018 R1200GS with the TFT display.

All firmware & software updates that I can find have been completed... and I am working from my MacBook Pro laptop.

The tool is completing the Autoscan function, and giving the details of my bike... but when I go to the VIN list, it does not show my bike's VIN saved (it's a new device, and the list is empty).

When I try to reset the Service interval... it also tells me that the function can't be completed because my VIN isn't stored.  When I try to "Add VIN"... the "Busy" notification appears on my screen for less than 2 seconds, then briefly shows (disconnected)... and I'm back to the previous status quo.  I can click on the "ADD VIN" icon again, and the same result occurs.

Please advise.

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Saving VIN to GS 911wifi
« Reply #6 on: March 20, 2021, 02:58:14 AM »
Hello... I am having the same issue as the OP during my initial use & setup of the tool on my 2018 R1200GS with the TFT display.

All firmware & software updates that I can find have been completed... and I am working from my MacBook Pro laptop.

The tool is completing the Autoscan function, and giving the details of my bike... but when I go to the VIN list, it does not show my bike's VIN saved (it's a new device, and the list is empty).

When I try to reset the Service interval... it also tells me that the function can't be completed because my VIN isn't stored.  When I try to "Add VIN"... the "Busy" notification appears on my screen for less than 2 seconds, then briefly shows (disconnected)... and I'm back to the previous status quo.  I can click on the "ADD VIN" icon again, and the same result occurs.

Please advise.

I would definitely lodge a support ticket with Hexcode, since you are on a MAC checking with the PC App is not possible unless you can set up Parallels or another Virtual Machine system  - https://www.hexcode.co.za/contact-us-1

ATCguy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Saving VIN to GS 911wifi
« Reply #7 on: March 20, 2021, 03:18:50 AM »
I would definitely lodge a support ticket with Hexcode, since you are on a MAC checking with the PC App is not possible unless you can set up Parallels or another Virtual Machine system  - https://www.hexcode.co.za/contact-us-1

Thanks for the reply, but I’m not quite sure what you’re saying.

I’ve downloaded & am using the appropriate GS-911WIFI app from the Apple App Store... not the PC app.  After connecting the tool to the bike, and turning the bike on... I click the link at the bottom of the App interface, which then opens a webpage in my browser (Safari).

From the webpage, the bike model is detected... I can run the Autoscan, and everything works as advertised.  That is until I go to the “Special Functions” link, and click on the reset service interval, and it says my VIN isn’t stored.  I try clicking on the Add VIN link... and it just won’t take.  I get the “Busy”, then “Disconnected” notices at the top of the page.

I can go try it again... take screen shots... and post them if you think it would help.

I was hoping I just had the power-up sequencing wring or something... I guess not.  :(

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Saving VIN to GS 911wifi
« Reply #8 on: March 20, 2021, 03:29:44 AM »
I would definitely lodge a support ticket with Hexcode, since you are on a MAC checking with the PC App is not possible unless you can set up Parallels or another Virtual Machine system  - https://www.hexcode.co.za/contact-us-1

Thanks for the reply, but I’m not quite sure what you’re saying.

I’ve downloaded & am using the appropriate GS-911WIFI app from the Apple App Store... not the PC app.  After connecting the tool to the bike, and turning the bike on... I click the link at the bottom of the App interface, which then opens a webpage in my browser (Safari).

From the webpage, the bike model is detected... I can run the Autoscan, and everything works as advertised.  That is until I go to the “Special Functions” link, and click on the reset service interval, and it says my VIN isn’t stored.  I try clicking on the Add VIN link... and it just won’t take.  I get the “Busy”, then “Disconnected” notices at the top of the page.

I can go try it again... take screen shots... and post them if you think it would help.

I was hoping I just had the power-up sequencing wring or something... I guess not.  :(

Yes I understand you are using the browser interface to access the GS911, with a MAC you can also use the PC App if you set up a Virtual Machine with Windowa, I am on Linux & use the Browser most of the time but also have a Virtual Machine with windows to use the PC Application

ATCguy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Saving VIN to GS 911wifi
« Reply #9 on: March 20, 2021, 04:36:25 AM »
Yes I understand you are using the browser interface to access the GS911, with a MAC you can also use the PC App if you set up a Virtual Machine with Windowa, I am on Linux & use the Browser most of the time but also have a Virtual Machine with windows to use the PC Application

Ok, I'm still not feeling ya.  Although I do have Windows booted to my MacBook via Parallels... I'm supposed to be able to use this thing without having to go thru using Mr. Gates features.  The tool is supposed to work on any Apple platform without the use of any Windows/PC interface.

That said, I figured I'd go back out and try it with my iPhone & iPad... since it's also supposed to work freely with those.  Same result... screen shots in succeeding posts below if I can attach them correctly:

ATCguy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Saving VIN to GS 911wifi
« Reply #10 on: March 20, 2021, 04:44:19 AM »
OK, this forum platform won't allow me to attach the screen shots.  I've tried adjusting the size, only attaching 1 at a time, etc... no joy.  Keep getting an "Internal Server error"... Sheesh!!

Guess I'll just contact HEX, and see if they can work it out for me

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1296
  • Karma: +27/-1
Re: Saving VIN to GS 911wifi
« Reply #11 on: March 20, 2021, 04:56:31 AM »
Yes I understand you are using the browser interface to access the GS911, with a MAC you can also use the PC App if you set up a Virtual Machine with Windowa, I am on Linux & use the Browser most of the time but also have a Virtual Machine with windows to use the PC Application

Ok, I'm still not feeling ya.  Although I do have Windows booted to my MacBook via Parallels... I'm supposed to be able to use this thing without having to go thru using Mr. Gates features.  The tool is supposed to work on any Apple platform without the use of any Windows/PC interface.

That said, I figured I'd go back out and try it with my iPhone & iPad... since it's also supposed to work freely with those.  Same result... screen shots in succeeding posts below if I can attach them correctly:

Yes the GS911 WiFi has firmware inbuilt for using web browser coupled with access to the Hexcode web server for full maintenance capability

Since you also have Parallels operational on the MAC you can also use the PC Application & when using the PC App the "intelligence" is in the PC App with the WiFi effectively acting as an interface only, this enables confirmation of where any issue is coming from

I have the PC App on the VM I use to access the GS911 WiFi via TCP/IP  so I dont need to use USB cable, often done this way in workshops

Download & install the PC Application from Hexcode into the parallels Win VM  & see how you go with it compared to using the browser interface