Author Topic: Help! I just got a GS911  (Read 362 times)

Gknight8

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Help! I just got a GS911
« on: October 29, 2019, 06:29:26 PM »
I just got a older USB GS911 and was wondering if any one know s if the GS911 will tell me if one of my spark plugs isn’t working/firing? I have a 1200RT with 2 spark plugs but it seems like the 2nd plug on both sides are not working because it is dirty not tan color like the main plug and I can smell gas on it. Thanks in advance and sorry if this has been answered before

schuppi

  • Sr. Member
  • ****
  • Posts: 390
  • Karma: +13/-0
Re: Help! I just got a GS911
« Reply #1 on: October 29, 2019, 06:53:56 PM »
Hello and welcome,

but sorry, there is no way to read the function of these spark plugs.
Thats old school mechanic work.
But these components are known to have a relatively short life span
 and often the contacts are broken.

Good luck
Schönen Tag
Wolfgang
                                       talk less, drive more

Gknight8

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Help! I just got a GS911
« Reply #2 on: October 29, 2019, 07:02:49 PM »
Thanks for your quick response! I guess I’ll have to resort to the keep replace
Ing parts and pray it works, lol.

Paul Hoffmann

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +1/-0
Re: Help! I just got a GS911
« Reply #3 on: October 29, 2019, 10:23:17 PM »
I have not had a RT but on my GS the lower (secondary) plug was always black compared to the primary and a petrol film is not uncommon.
You could replace all plugs so you have a base line from which to work from, your money so your choice.

Gknight8

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Help! I just got a GS911
« Reply #4 on: October 30, 2019, 06:38:24 PM »
Thanks for the info I didn’t realize that being a little oily and gas smell on the secondary plugs were normal I guess there’s more to learn about these hexheads.