Author Topic: New GS911 - not working even in USB mode  (Read 454 times)

pongo

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
New GS911 - not working even in USB mode
« on: July 10, 2019, 05:04:21 PM »
Hi. I just got my new GS911 Wifi. It is registered correct and firmware is updated. Tried to get it connected in wifi mode and to my iphone but i gave that up. It does not register anywere. So i changed it to USB mode and connected it to the bike which is a 2017 S1000XR. I use the 10 pin 911 version with OBD extender also bought at hexcode. When connecting the plug to the bike i do get a message that it obviously recognize that it is connected to a bike. Then switch ignition on after selecting correct bike model and try to perform autoscan. I get an error message that the ignition is switced off. Started the bike. Same error message.

I really do not need this hazzel. It did work fine with the older version but needed a new instrument when upgrading bike. So, what am i doing wrong:

1) In USB mode the GS911 does not recognize that the ignition is switched on and therfor i cant use it
2) It is registered, verified, updated but no coms in wifi mode
3) Is it supposed to be charged by USB and then used wireless, or does it get power from the bike.

Bike is on center stand. In Neutral. Side stand up. I start the bike. Connect GS911. Get errormessag that it can not read from the controller. Bike is brand new. Only 5500K. Brand new and un-used extender cable. Brand new GS911 that i finally got to work on browser mode and app mode

Regards Leif
« Last Edit: July 10, 2019, 06:53:42 PM by pongo »

pongo

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: New GS911 - not working even in USB mode
« Reply #1 on: July 10, 2019, 11:07:50 PM »
So the new FAILING toy does not work on my 07 K1200GT either. Same error message. I am not impressed!

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 949
  • Karma: +18/-1
Re: New GS911 - not working even in USB mode
« Reply #2 on: July 11, 2019, 03:16:25 AM »
The problems you are having when connecting via USB sound a little odd so I would suggest you lodge a support ticket with Hexcode https://www.hexcode.co.za/contact-us-1

The GS911 is clearly seeing the bike when you connect it & is prompting you to do an autoscan, I would normally just turn on ignition then press OK  & it does the autoscan.  With the OBDII connector bikes I have not had any problems diagnosing the bikes using USB & the latest PC software, with some older models you just click past the Ignition Voltage message

Re the WiFi connection since there are different WiFi modes a little more info on that would be needed to assist you

Re power to the GS911, it gets power from the bike

pongo

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: New GS911 - not working even in USB mode
« Reply #3 on: July 11, 2019, 06:56:19 AM »
Wayne, thank you for replying. The different modes; usb, wifi, app/browser is working now. Allthough the red button works any other time.

I did a final test on the 2017 bike. Started it. Drove it until warning lights went out. Parked it in idle. Connected the GS, select bike etc but same error message. Clicked past that but could not collect any fault codes due to no ign.

A ticket is established. 

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 949
  • Karma: +18/-1
Re: New GS911 - not working even in USB mode
« Reply #4 on: July 11, 2019, 08:30:16 AM »
No worries, with WiFi remamber there are Intrastructure mode for the GS911 to log into your phone hot spot or home WiFi router so you gain access to cloud services maintenance routines then there is D2D mode for the phone to log into the GS911 & use basic functions, start real time logging etc

With USB & PC App, there is no need to select bike model, you can just do autoscan from main menu & it determines which model for you, try that, with the later models & CAN DIag BMW dont extend Ignition On to the diagnostics socket, diagnostics gear gets V-Ign info from the ECU
« Last Edit: July 11, 2019, 08:32:33 AM by WayneC »