Author Topic: Husqvarna Service Light  (Read 1073 times)

craig

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Husqvarna Service Light
« on: September 03, 2018, 02:27:32 PM »
Tried several paths to get some information on resetting a service light on my 2013 Husqvarna TR650 Terra. I have two Terra bikes. sent off both of the ECU's to be reprogrammed. The first bike ECU failed after being reprogrammed. Three months later KTM sent a new ECU, dash, seat lock and EWS. (no gas cap, so now i have two separate keys). The second bike had no issues with the after the reprogrammed ECU was installed except the engine service light is on. The dealer sells  KTM /Husqvarna. They did not sell Husqvarna until after KTM bought Husqvarna from BMW. They did not have access to the BMW CAN bus programmer.
I bought a GS-911 to be able to access the CAN bus. I can connect and do system scans. The system was connected with the following path. (GS-911WIFI |Series|H|TR650 Terra|Service functions) Error: Attempting to connect to this controller caused a negative response. Possible reasons: Module is not the expected type or Wrong model or family selected.
I am not sure what is causing the service light to be on. there were no error codes present during the AutoScan. The service due date was 01-01-2011. No fault codes on BMSE or KOMBI18. All the instrument cluster function test worked. The only thing I did notice was the temperature was showing 0 volts. The temperature reading on the dash seemed to be correct.
would appreciate any help, Regards, Craig

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 949
  • Karma: +18/-1
Re: Husqvarna Service Light
« Reply #1 on: September 04, 2018, 02:59:36 AM »
Craig, firstly the the Dealer System is not a "CAN BUS Programmer" the system handles multiple different interface protocols, the diagnostics interfaces between Diags PC & car/bike can be K-Line, CAN-Diag or Ethernet dependent on model

On the TR650 the diagnostics interface is K-Line, CAN BUS is only used for comms between ECU's BMS-E, Dash, ABS & DWA

Re the Service Lamp it is likely to be on due to the 2011 service date and you should not have problems setting a new service date since it is clear the GS911 is communicating with the bike, were you using USB cable comms to the GS911 ?

Which model of GS911 did you purchase ?, what PC are you using (PC/MAC/Windows Version) and what applications have you installed ?


craig

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Husqvarna Service Light
« Reply #2 on: September 04, 2018, 06:20:28 PM »
I purchased the GS911wifi 10 pin. I was connected to a PC operating with windows 10 via wifi. I have the  wifi utility and GS911 1807.2
applications installed. I will go and try to reset the service light again. I could get to to the point of having access to the reset function. The error message prevented initiating a reset. Should I try and access the reset function through the K series path ?
I sure appreciate your help. Regards, Craig

craig

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Husqvarna Service Light
« Reply #3 on: September 04, 2018, 09:18:19 PM »
Tried to access via WIFI...error. tried USB, connects ok, set the model to diagnose and get error message "( detected the following problem: failed to read controller info; no response from controller, check that the; ignition is on, kill switch is in the run position, neutral is selected, immobilizer is deactivated (if fitted). Do you wish to continue anyway (Note that ABS functionality will be limited)? " If you select NO it kicks you back. ( checked status of all the items listed for possible failed to read controller issue. Everything showed the proper state in the status log. If you select yes it will allow you to access other functions but i can no longer gain access to reset service reminder. One other strange item to note. during a function test the RED warning light test illuminated the ABS warning light ??? Also received the error message  ( failed to communicate with controller: invalid target several times while trying to get around the functions. HELP !!
Regards, Craig

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 949
  • Karma: +18/-1
Re: Husqvarna Service Light
« Reply #4 on: September 05, 2018, 05:26:34 AM »
Craig, sounds odd, understood re GS911 model & software you have installed, is the GS911 WiFi firmware fully updated ?

I can only assume the "failed to read controller" error meant a problem with comms from GS911 to BMS-E which acts as gateway to all other ECU's yet it had clearly worked previously, when you are connecting are you simply doing an Autoscan from main menu or manually selecting the model series etc from the menu ?

In terms of working with the TR650 diagnostics the things I always do are

1/ Pull the fuse for the headlight, the headlight is the highest power item & extended sessions can heat damage the headlight reflector

2/ Connect a charger/power supply to the battery to keep voltages up while doing diagnosis, the power consumption is less than 2 amps with headlight disconnected so most chargers do the job well, in line with BMW requirements I try to ensure 14v

I would quickly check all connectors are seated home properly just to be sure, I assume the GS911 shows power when plugged into the diags socket before you turn on ignition

With BMS-E models like the TR650 I also ensure the owner has fitted an external earth link to the BMS-E case due to the known weakness in the earth connections through the socket & the problems some have had with damaged BMS-E's

Can you post an Autoscan in the thread so we can see the info ?
« Last Edit: September 05, 2018, 05:28:47 AM by WayneC »