Author Topic: K1200RS hesitates and runs rich  (Read 781 times)

2000K1200RS

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
K1200RS hesitates and runs rich
« on: July 21, 2017, 06:41:28 PM »
Hello all,

This is my first post here. My 2000 K1200RS, which I have had for more than 5 years has always run rich. It also hesitates on accelerating but in general I have no problem cruising and it has all the power. I can also smell that the engine runs rich, and fuel efficiency is in low 30s.

I did lambda voltage test and there were long periods of flat voltage, so I changed the O2 sensor. I believe the problem is somewhere else, because this is not the first time I have changed the O2 sensor.

I am posting results after changing the O2 sensor. There are two graphs: First one is while idling and in the second one I tried to increase RPM to 2000 and 3000 and then released it to idle. I noticed that the O2 voltage was showing flat when it idled after revving. Can you comment on these graphs? Engine was hot (tested after a 15 mile ride) in both cases.

I am also plotting the TPS on the graph. It seems to be changing, but I notice that it doesn't follow the RPM properly.
I also have a question regarding O2 sensor itself. Can it go bad by carbon fouling from a rich engine?

I have not really checked the throttle body, air filter and everything that is inside the fairings. If I remove the fairings, I would like to do all the necessary checks and maintenance, so any recommendations will be greatly appreciated!

I have the data for both these tests, so let me know if it will be useful to plot any other variables.

2000K1200RS

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: K1200RS hesitates and runs rich
« Reply #1 on: July 21, 2017, 06:45:35 PM »
A correction: The blue curve in the first graph is indeed for TPS. The right side Y axis shows ignition time incorrectly (because I had it there earlier and then removed it and then forgot to change it in Kaleidagraph). Thanks

Jughead

  • Beta testers
  • Sr. Member
  • *
  • Posts: 476
  • Karma: +35/-2
    • Dual Sport Motorcycle Clinic
Re: K1200RS hesitates and runs rich
« Reply #2 on: July 24, 2017, 06:24:22 PM »
Try plotting just the lambda on it's own.  You should get a graph similar to the attached but with only a single graph.  The attached is for an R1200GS with twin lambdas.