Author Topic: ESA calibration not available on my ESA bike  (Read 3957 times)

cosi

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
ESA calibration not available on my ESA bike
« on: October 07, 2013, 10:56:04 AM »
Hi

New beta 1309 version does recognize ESA on my K1200R 2006 model.
What's Up??

Thanks
C

wilkoo

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: ESA calibration not available on my ESA bike
« Reply #1 on: October 11, 2013, 09:53:25 PM »
same for me, calibration not available on my k1200gt 2007
what's the problem ?

MikeSF

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: ESA calibration not available on my ESA bike
« Reply #2 on: August 30, 2016, 12:33:42 AM »
The GS-911 only works on ESA II that has Hall Effect position sensors. I am not sure when these were introduced but believe it was approx 2009. Hex have known for years that the older ESA I units with potentiometer position sensors cannot be calibrated and recently I was advised by Hex support that they have not managed to get a bike to work on a solution to the problem. It's a real pain as many of us with old ESA units are left stranded. Having said that, there is a post whereby somebody has managed to use the GS-911 on an ESA I bike and "fooled" it into running the calibration routine. I got someone to do this on my 2006 K1200R on which the only thing that did not work was the preload adjustment and after trying I had totally lost all ESA functionality. No icons in the display whatsoever. I ended taking the bike to a BMW dealer and even they could not calibrate the preload adjuster. I ended up leaving the bike without ESA functionality. Not happy.

Old goat

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: ESA calibration not available on my ESA bike
« Reply #3 on: August 30, 2016, 10:04:17 AM »
I had exactly the same experience as MikeSF on my 2005 R1200RT, including the BMW dealer involvement. I've since fitted a pair of non-ESA suspension units and I must say that I am completely satisfied with this.

durinkos

  • Newbie
  • *
  • Posts: 26
  • Karma: +0/-0

MikeSF

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: ESA calibration not available on my ESA bike
« Reply #5 on: March 05, 2017, 07:18:23 PM »
Further to my previous post I have done further work on my 2006 K1200R in order to see if I can get the ESA working again. Rather than hand the bike over to the local BMW agent and pay £100+ per hour to investigate I decided to do the work myself. Unfortunately I was unable to get hold of a wiring diagram so decided to trace the wiring from the front and rear ESA units back to the ZFE controller. Attached are my findings. If anyone who has a fully functional K1200R (pre Hall Effect) and would like to advise the readings they have from the front connector of their ZFE it would be much appreciated. Whilst I haven't returned to the dealer yet to have the ESA re-calibrated I feel that the root cause of my problem was in fact the preload adjustment motor which was faulty.

Note: The preload position readings were taken with the suspension unit in the softest position and the reading for the preload motor relates to a second hand unit that I have fitted. The original motor only showed a resistance of 2.4ohms so I think it had burnt out. Hopefully the motor hasn't messed up the ZFE electronics. I will update this post once I have taken the bike back to the dealer to have it configured and calibrated which should be later this month or next.

« Last Edit: March 05, 2017, 07:32:21 PM by MikeSF »

MikeSF

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: ESA calibration not available on my ESA bike
« Reply #6 on: March 05, 2017, 08:26:00 PM »
Update on my last post to show where to take the readings at each suspension unit rather than just the ZFE connector.