Author Topic: Accessory circuit "just stopped working"  (Read 5246 times)


  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Accessory circuit "just stopped working"
« on: October 02, 2022, 08:28:39 AM »
Hi, thought I'd pass on my recent experience:
Last year, got BD lights & Innovv K2 camera working on R1250GS with Gen 2 EZCan.
K2 on yellow accessory circuit using 3rd wire on 60 second delay so last video being recorded gets written without being corrupted.
Recently had a small bitumen/dirt nap, scratched plastics, broke mirrors - the usual.
After retrieving bike & getting it all riding & looking sweet again noticed:
1. BD lights still working
2. Innovv K2 cameras not working
Long story short:
EZCan yellow accessory circuit has 3 wires - earth (black) power (yellow) & trigger (yellow/black). Red had power (13+V), trigger had nothing.
Circuit was shown (via software via usb) to still be active.
Forgot to check diagnostics, just disabled yellow circuit then re-enabled it again, & power to trigger wire returned & camera started working again.
It would be useful to find out what might cause this issue.
I'm just lucky I thought to look for voltages the toggle the circuit off/on to see if that worked.
Any similar experiences & perhaps diagnostics results would be welcomed


  • Administrator
  • Sr. Member
  • *****
  • Posts: 252
  • Karma: +5/-0
Re: Accessory circuit "just stopped working"
« Reply #1 on: October 11, 2022, 02:31:08 PM »
Hi Solar

That's quite a specific sequences of events. Was the ignition toggled a couple of times prior to the enabling/disabling of the output, or was it a more straight forward, get home, start troubleshooting?

Kind regards


  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Accessory circuit "just stopped working"
« Reply #2 on: October 17, 2022, 06:06:20 AM »
Short answer -Yes, ignition on bike toggled many times, also pulled fuse to EZcan. No 'reset of virtual fuse' as expected, had a fuse overload been the cause.
Long answer - I analysed from first principals, using multimeter to trace actual voltages. Long sequence of events, in no particular order: Cam LEDs on controller found to be not lit, so enabled wifi on phone & Innovv app to see cam not powered up/online. As cam is powered by Hex EZCan accessory circuit with power, earth & trigger, used multimeter to confirm power was coming out of EZcan but Innov controller relay not being activated by trigger, ergo: trigger not alive. Had to go buy very long USB cable to connect EZcan to Mac Mini inside house. Ran software & it showed all configured circuits active, with current limits as I had set months ago. Didn't look at diagnostics for cam's accessory circuit (mistake) - just toggled that circuit off & on (with green slider button, IIRC). Innovv camera then sprung to life & now all good.
Question is: Why does EZcan software interface show accessory circuit is on & active when it was clearly "configured to be active" but "not on/active".
According to doco, cycling the power to EZcan should reset any "blown virtual fuse", but that didn't work for me. Only toggling circuit OFf then ON again worked.
Would be inconvenient if I was away from home/computer! I carry an iPhone, so software that used BT/USB/wifi from EZcan to phone would be a great long-trrm fix.
« Last Edit: October 17, 2022, 06:14:52 AM by solar-g »