Author Topic: switching cam adjuster 2 output stage, open circuit on R 1250 GS hp 2019  (Read 3496 times)

remyredjo

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Hi Guys

i have a 2019 BMW r1250 GS HP

Got a message on my screen saying " serious fault in engine control , onward journey possible damage possible, have checked by a workshop"

i connected my gs 911 wifi with usb cable to my laptop and got the folowing message from my engine control
" SWITCHING CAM ADJUSTER 2 OUTPUT STAGE, OPEN CIRCUIT "

I already cleaned the crank sensor at the left cylinder and also plus the cable out from both cylinders to the

if i clear the code and engine is warm the code does not come back

the other morning when the bike is cold
you get the message again and sometimes it gifts you a check engine code


guys did somebody else have this issue already and how to solve it

there is no BMW dealer in the area where i live

regs



Ruan

  • Administrator
  • Full Member
  • *****
  • Posts: 244
  • Karma: +5/-0
Hi Remyredjo

Could you send us an autoscan of the bike while the fault is active? Simply download the autoscan at the bottom of it, and paste the text here in a response. We'll be able to get a bit more information with the exact fault and controller info.

Kind regards
Ruan

remyredjo

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Hi Ruan

i connected my GS911 WIFI to the bike a R1250 GS HP from 2019

and get the following if i activate the camshifter through the scanner :

A negative response was received from the vehicle; The preconditions or sequence order was not met for this controller

If the bike is warm and you clear the codes everything seems to work fine

the first start in the morning shows you the warning again


personally i think that the shifcam motor is sitting in a position that it not must
So if you turn on the bike in the morning it gives you a error

If somebody out there has similar problems pls be kind to share the fixing procedure for this

i m advised to open op the head and change the shiftcam from lef to right to trouble shoot it


looking for your advise worldwide

regs
Remy

ps i try to attache screenshots but the forum does not alow me


botus

  • Beta testers
  • Full Member
  • *
  • Posts: 205
  • Karma: +3/-1
the mechanism that smashes the cam side ways to move between the different lobes has a 60k mile service life

and at 4 years likely an age related "issue" too - the idea today is lease for 2 years and throw in a skip... that way the rich don't have any issues (or indeed need to wash the bike) and you keep paying for the dev features they can enjoy....

Jughead

  • Beta testers
  • Hero Member
  • *
  • Posts: 768
  • Karma: +51/-3
    • Dual Sport Motorcycle Clinic
the mechanism that smashes the cam side ways to move between the different lobes has a 60k mile service life

and at 4 years likely an age related "issue" too - the idea today is lease for 2 years and throw in a skip... that way the rich don't have any issues (or indeed need to wash the bike) and you keep paying for the dev features they can enjoy....

WALOC!

botus

  • Beta testers
  • Full Member
  • *
  • Posts: 205
  • Karma: +3/-1

WALOC!

so you haven't noticed the paint and surface finishes NOW have the durability of single ply tissue paper or that the Germans spent the last 25 years on alchemy turning base metal into gold - at the parts counter - get real !


Jughead

  • Beta testers
  • Hero Member
  • *
  • Posts: 768
  • Karma: +51/-3
    • Dual Sport Motorcycle Clinic

WALOC!

so you haven't noticed the paint and surface finishes NOW have the durability of single ply tissue paper or that the Germans spent the last 25 years on alchemy turning base metal into gold - at the parts counter - get real !

And this is related to the GS-911 how exactly?

halejl

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
remyredjo, did you figure out what was causing the negative response on the switching cam test? I’m having the same result on my 2019 R1250GSA. Have you had any problems with the bike since the incident?

Jerry