Author Topic: ezCAN Gen II power failure  (Read 408 times)

oplemieux

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
ezCAN Gen II power failure
« on: November 05, 2020, 03:50:02 AM »
Today my exCAN Gen II failed, none of the circuits are working, the blue light on the ezCAN is OFF.

Check the power wiring from ezCAN to the battery terminals connections OK, battery power at these terminals is OK, checked the 30amp fuse OK.

All was working yesterday, started bike this morning none of the devices are working.

Nothing new has been added since first installed earlier this year. (Denali lights 1 pair, powered tank bag, brake light)

Plugged laptop into the device, no device found.

Appears to be an ezCAN device failure.

Please contact me about steps, assume it is under warranty, purchased earlier this year.

Ruan

  • Administrator
  • Newbie
  • *****
  • Posts: 11
  • Karma: +0/-0
Re: ezCAN Gen II power failure
« Reply #1 on: February 23, 2021, 02:48:26 PM »
Hi There

Could you please do the following for me to perform a "hard reset" on the device:
  • Disconnect from your bike's RDC/DWA and the battery (or remove fuse) for around 10 minutes.
  • Keep it disconnected from your laptop for this duration as well.
  • Connect it to your laptop using the supplied USB cable or a different DATA USB cable and check whether the status LED illuminates.
  • If it does not, please check with a different USB port or if possible, a different PC to ensure that the device receives power and communication.

If the unit remains unresponsive, please contact us on our helpdesk below as we'll need to get you sorted with a warranty replacement unit:
https://www.hexezcan.com/contact-us/

Kind regards
Ruan

oplemieux

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: ezCAN Gen II power failure
« Reply #2 on: February 23, 2021, 05:16:58 PM »
Hello Ruan,

We already worked this one through, you and I determined the ezCan had failed and I returned it to the vendor I bought it from "Twisted Throttle" and they sent me a new one, I installed it and everything is working perfectly, now I just need winter to finish up and I'll be on the road again.

Thanks again for the great support, much appreciated.

Owen

Ruan

  • Administrator
  • Newbie
  • *****
  • Posts: 11
  • Karma: +0/-0
Re: ezCAN Gen II power failure
« Reply #3 on: February 24, 2021, 10:08:24 AM »
Hi Owen

I see, I'm glad to hear you are up and running (soon again, at least)! Luckily we have reasonably rider friendly weather in South Africa year round, so I hope you can get an early spring :)

Kind regards and safe travels
Ruan