Author Topic: engine stalls when warm/hot. K1200S  (Read 6669 times)

ricknut

  • Beta testers
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
engine stalls when warm/hot. K1200S
« on: June 01, 2013, 02:48:45 AM »
Hi,

engine stalls when warm/hot. K1200S. I suspect that the engine Idle controller motor is at fault. burnt rotten eggs smell from exhaust. Usually happens when sitting in traffic. I use 93 premium gas. any ideas?

ricknut

  • Beta testers
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: engine stalls when warm/hot. K1200S
« Reply #1 on: June 02, 2013, 01:40:37 AM »
so.. I have a venting problem in my gas tank. When the gas cover/lock is unlocked, the idle problem and surge issue seems to go away. Is there a way to clear the vent hole at the top of the gas cover? The gas tank is not venting correctly and is causing fuel distribution problems. This is a problem when cruising with an empty tank and this is causing the gas tank to shrink or swell. Not getting any engine codes. Problem only occurs when the gas cover is locked.

kobus

  • Administrator
  • Full Member
  • *****
  • Posts: 180
  • Karma: +11/-1
    • GS-911
Re: engine stalls when warm/hot. K1200S
« Reply #2 on: June 03, 2013, 10:51:31 AM »
Not sure why it's not venting. Check all the plumbing for kinks. This is a US model, so it might have something to do with the evap valve plumbing (or possibly the evaporation valve itself).

What I do suggest is that you get it fixed quickly because a tank that does not vent properly will cause your fuel pump to fail eventually.
---
R1200GS Adventure (personal weapon of choice)
... and then the company fleet.

ricknut

  • Beta testers
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: engine stalls when warm/hot. K1200S
« Reply #3 on: June 03, 2013, 02:17:04 PM »
Thanks for the reply. I checked the Rem Rom tech manual and suspect a crimped line.

I will check gas flange, check lines and will do the eval test. Yes, I do agree and very nerve racking when you are cruising 75 mph and bike stops working.  :'(

ricknut

  • Beta testers
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: engine stalls when warm/hot. K1200S
« Reply #4 on: June 03, 2013, 06:52:09 PM »
More testing on evap system first.
suspect. I might try to drill hole in fuel neck.
http://www.i-bmw.com/showthread.php?t=28824