Author Topic: F650 CS 2 - spark 2005 : 1508: Rear sensor fault, signal implausible.  (Read 4916 times)

stardust_59

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
Re: F650 CS 2 - spark 2005 : 1508: Rear sensor fault, signal implausible.
« Reply #15 on: September 07, 2018, 02:06:43 AM »
The saga continues -
tried a dash from an f650GS.
Same result :
1508: Rear sensor fault, signal implausible.

After that : exchanged the ABS with another one and tried again.
The replaced ABS faithfully does everything you tell it to do.
All initial tests ok. Bleeding works like a charm.

Running the bike after ABS replacement,  brake bleeding etc:

Same story all over.

ABS check lamp ok after iginition on.

Drive a couple of hundred meters.
ABS fault blink.

GS911 ABS faults: 1508: Rear sensor fault, signal implausible.

Looks like I will have to start from scratch checking the wiring harness again.

Problem:
I would like to hook up some osci probes to the relevant connections in the live system - but BMS and ABS connectors and leads are almost inaccessible.
Any ideas for adapters of sorts for the BMS / ABS connector ?


To touch the subject again -
the rear ABS sensor signal goes into the ABS, then from there into the dash , where it is conditioned and splits into
- a) path the dash processor
- b) path to BMS-C

I suspect somewhere in that path there must be a fault.

I exclude the dash as fault cause , since the F650 dash showed the same symptoms.
It was taken from a fully working F650GS R13 / ABS / 2000

I looked at the PCB of the CS and the GS dash and the components as well as the PCB are similar , with the exception of a jumper being soldered in on the CS PCB.
The signal path components we talked about earlier are the same, the dash chip is the same.

I would be happy about any input ..


WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 949
  • Karma: +18/-1
Re: F650 CS 2 - spark 2005 : 1508: Rear sensor fault, signal implausible.
« Reply #16 on: September 07, 2018, 03:18:25 AM »
The dash pcb's for CS/GS are the same 00-09 with a couple of different hardware revisions, the firmware is different CS/GS 00-04 & GS 05-09, the GS has dedicated firmware for MPH & KPH where the CS is the same for MPH/KPH & uses a hardware link to change between MPH/KPH

This thread shows how another model owner used a DSO to test the wheel sensor http://forum.hexcode.co.za/forum/index.php/topic,1506.15.html

stardust_59

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
Re: F650 CS 2 - spark 2005 : 1508: Rear sensor fault, signal implausible.
« Reply #17 on: September 07, 2018, 07:55:35 PM »
WayneC,
thanks for the link.

Checking the signal from the rear sensor using the wire with the resistor in series is known.

I did this already and I have the harness.

The replacement sensor is original BMW, brand new and it gives a signal. That was one of the first things I checked after installing the new sensor.

The question is why does the signal not reach the BMS-C ?

If the signal reaches the dashboard ther should at least be a speed indication on the speedometer and a reading with the GS911.
But there is no speed reading.


WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 949
  • Karma: +18/-1
Re: F650 CS 2 - spark 2005 : 1508: Rear sensor fault, signal implausible.
« Reply #18 on: September 08, 2018, 03:17:16 AM »
OK understood you fitted the new sensor & checked the output at the sensor socket, I assume you confirmed wiring continuity to the dash & if that is all correct then the question would be whether the dash input circuit is operational.

The dash massages the signal a little then outputs the speed signal to the BMSC on pin 6 to BMSC pin 21, the Blue/Yellow wire