Author Topic: CANbus Resistance Values  (Read 22344 times)

marki_gsa

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: CANbus Resistance Values
« Reply #15 on: July 25, 2013, 08:25:56 PM »
Aha.
OK, I understand now.
But the dealer did not have to change anything to do this.
The newer LED's come complete with resistors to make the CANbus system think you still have the OEM bulbs.
You just plug in the new ones.
I did this myself on my bike: I installed them myself.
No errors either.
You have to order the resistors as an extra though, and the parts guy for my dealer did not know that the extra "harness" was in fact a resistor to do this.

My only issue was I needed two sets of rear LED's since the front set don't fit the HP2.
But they are great LED's I agree.

The aftermarket ones do this the OEM ones don't, the option gets changed in the zf IF the bike had options of LED or bulb. 2009 comes to mind where you could get a normal or LED tail light or indicators. Personally I see no point in running LED lights and then sticking resistors in line to bring the load up. The whole point of LED is reduced power consumption which you loose with the resistors.

WarthogARJ

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
Re: CANbus Resistance Values
« Reply #16 on: July 26, 2013, 11:57:49 AM »
Hi Marki-GSA,
Thanks for that.
Yeah it seems my 2006 HP2 Enduro bike was done pretty soon after CANbus was introduced, so not so many options about adding in LED without ZFE/"CANbus errors", or nasty power resistors.

I agree about it being a disadvantage to run power resistors as well as the LED.
However the advantages you DO get are:
- Reliability: LED's don't burn out like incandescent bulbs do
- Brightness: can get brighter LED's and also HiD's

It also depends how you ride: if most/all your riding is on smooth tar then your OEM incandescent bulbs probably last a long time.
If you rattle them round off-road they do not always.
And if you don't ride in places with goats, sheep and camels on the road when you ARE riding at night, well, maybe you don't need bright HiD lights.
And whatever anyone says, you DO ride at night: kak happens, you don't always end up where you want to be when it gets dark.

But since the alternator puts out 600 Watts and my bike engine 110 hp, it's not REALLY like I'm missing the juice to heat up the resistor.
But it DOES seem wrong I agree.

The IDEAL way would be for some clever company to figure out a way to interface with the BMW system and change the resistance values....
Hmmmmm, I wonder WHO is smart enough to do stuff like that?...:-}
But again, if it's hardwired in the ZFE then even the mighty GS-911 cannot do it.

But another way is to use an LED with an extra resistor so the TOTAL resistance is the same as the OEM resistance: in series.
I just bought an LED bulb for the tail light that does that.
I screw it in and my tail/brake work fine without CANbus-type errors.
It takes me about 30-45minutes to undo my back end to change bulbs when the incandescent burns out: I have modified it from standard.

In any case, I LOVE the GS-911.
It means I can do a LOT of troubleshooting, even if there are a few things that sure would be nice to have.
And it also has an excellent forum for electrical issues.
Bonus: worth as much as the GS-911 at times!
Alan

Haakon

  • Full Member
  • ***
  • Posts: 145
  • Karma: +8/-1
Re: CANbus Resistance Values
« Reply #17 on: July 28, 2013, 12:29:54 AM »
Not exactly on the CANbus topic.... I risk it anyways :-)
I fully agree on your dislike of using resistors.
Incandescent bulbs do have a advantage compared to HID`s (Bi-Xenon type used as Halogen H4 replacement)
You have 2 separate filaments so if one burn out you are not left in pitch darkness (IF you remember to switch to Hi or Low) I have been using HID since 2008 (56 000Km) and never had any problems at all!
(only once- but that was when the external fuse had disintegrated :-)))
BUT, I know of people that have had HID`s fail ever so often.. for no reason at all.
If you convert to HID, a good advice is to fit a LED aux light too- then you have a "backup".
--------------
Have you found LED "bulbs" that can be used in the original headlight?
Ahh.. 2006 HP2- sorry, guess you have a 2 bulb headlight?- I did not think...  :-)) 
   
   
2000 F650-GS

WarthogARJ

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
Re: CANbus Resistance Values
« Reply #18 on: July 28, 2013, 03:22:12 AM »
I have a single bulb headlight: with an twin filament H4.
I used an HiD setup for 25,000km on a TransAfrican trip and it was OK.
But it used a power resistor.
I've just got a setup that works without a relay, right off the BMW wiring and it seems to work OK.
Installed this weekend.
No "CANbus" type errors.
So the total resistance must be a close match to the OEM.

So I'm not as desperate for the GS-911 to sort things out.

And yes, I have some auxiliary lights: with the newest Cree LED's.
Very bright.

But I haven't seen any LED bulbs that can be used in the headlight directly.
I think would be tricky.
Not only to do technically on my bike's headlight (well unless I completely replaced it) but also from the legal aspects.
I get away with HiD's, altho strictly speaking it fails the yearly MOT inspection.

I think only the new BMW has approved main headlight LED's.
But for sure that's the way to go.

StephanT

  • Administrator
  • Sr. Member
  • *****
  • Posts: 398
  • Karma: +17/-2
    • HEXcode
Re: CANbus Resistance Values
« Reply #19 on: July 30, 2013, 08:47:09 PM »
So, Stephen, what say?
You afraid of your dog or your wife?

Seriously, is it not possible to find the resistance look-up table in the firmware?
the wise man is afraid of both  ;D ...or to put it differently : "Happy wife... happy life..."

there are no lookups.. this is part of coding, and you can code it to be either standard filament bulb of OEM LED bulb.. and those are you only options... AND not all ZFE units support that... (the HP2 has a ZFE_Basic, and I'll have to look at whether it supports that function...)

best,
Stephan

WarthogARJ

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
Re: CANbus Resistance Values
« Reply #20 on: July 30, 2013, 09:17:00 PM »
Woof woof!!!
Bow wow.
Thanks.

And us HP2 Dudes prefer to think of it as a "Robust" and "Straightforward" machine rather than "Basic".... 8)

On a related topic, in my quest to complicate my life and spend money on eBay, I added LED bulbs for my tail/brake-light as well as my parking light bulb.
The tail/brake worked out OK: no CANbus reported errors and it works OK.
The LED bulb says "CANbus friendly" so I presume it uses a resistor to make it up to the same resistance as an OEM filament bulb.
The main advantage for me is hopefully not having to change the bulb: is a hassle to get at it with a few mods I've done.

The parking light LED swap was very strange though.
It works, and no GS-911 reported errors, however when you turn off the ignition the bulb stays on.
Not full brightness, but still on.
Took the key out too.
For HOURS too.....hmmmm.....
I swapped it back for the standard OEM filament bulb and it behaves as it's supposed to: turns off when ignition off.

i had ordered a 2nd type from eBay and I tried that one: is a bit more complicated than the 1rst one.
And THAT one works OK: goes off when supposed to and no GS-911 errors.
Brighter than OEM bulb too.
Hmmm......

So I think what happens is that the ZFE has a bit of leakage to the bulb: enough to light the LED slightly.
However why doesn't that drain your bike when the OEM standard filament bulb is in??
Is there a solid state switch in the ZFE that is not being turned off with the 1rst LED I used but IS turned off with the OEM bulb as well as the 2nd LED light?

Very strange