Author Topic: After upgrade to V2203.5 unit will not stay connected USB to bike  (Read 445 times)

JRWooden

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
I  HAVE  opened a support ticket but since it is Easter wkend thought I would post here also.
If  "we"  don't solve it I'll post the answer from support when I get it!  Here goes:

Yesterday I upgraded to the new release - 2203.5 on my GS-911 wifi unit which I have owned for several years.
I did this in my apt. connected to my Win10-64-bit laptop and everything upgraded just like it always has done.

Then I carted the laptop and 911 out to the bike. I needed to reset adaptation values for the gear-indicator and at least in the past,
have not been able to do that without the laptop.

I hooked the unit up to the bike and launched the new s/w and get a looping series of USB-connect --> USB-disconnect sounds.
The unit keeps connecting and then almost immediately disconnecting.  This does NOT happen if the 911 is UNconnected to the bike.

Interestingly the Hex-Device does not show up in the list of USB-devices in device manager.  :'(
(does not matter if unit is connected to bike or not - the Hex device is not enumerated).

Hex-Device does work fine in D2D mode.

Uninstalling and reinstalling the s/w on the laptop had no effect.

Thanks for any help!



« Last Edit: April 16, 2022, 04:14:15 PM by JRWooden »

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1297
  • Karma: +27/-1
Re: After upgrade to V2203.5 unit will not stay connected USB to bike
« Reply #1 on: April 17, 2022, 02:22:58 AM »
The update to v2203.5 is update of the new diagnostics PC App only not firmware within the GS911 WiFi so it should work with the old legacy PC App as it did before, do you still have the old legacy App v2104.1 installed on the PC ?

USB connect/disconnect sounds suggest a W10 USB issue, when was the last W10 update ?, install of the old PC App would ensure Hexcode USB drivers are installed

JRWooden

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: After upgrade to V2203.5 unit will not stay connected USB to bike
« Reply #2 on: April 17, 2022, 02:47:53 AM »
Thanks Wayne!

When I installed the new version of s/w it also installed a new "DataPack" I don't know what that is ... I think it was ver.  4.10 ?

I have the downloader for V 2004.3 so I could uninstall what I have now and re-install that ...

I did install this month's patches for W10  released on 4/12
That could well be a factor - funny that it only does it when the 911 is attached to the bike ...
BUT of course it does not show up as an enumerated USB device when NOT attached to the bike ...

I used D2D mode and found the 2 faults were trivial and reset them, so I'm good for now ...

I've got a lot going on this coming week (new granddaughter being born   ;-)
So knowing the bike won't blow up I'll likely ignore things till I hear back from support.

Whatever the solution turns out to be I'll post it here!

Thanks again,
Jim

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1297
  • Karma: +27/-1
Re: After upgrade to V2203.5 unit will not stay connected USB to bike
« Reply #3 on: April 17, 2022, 03:34:02 AM »
You dont need to uninstall the new PC App, it happily resides on the PC alongside the old legacy App, exactly what  I have on the test systems

The datapack is the data for all the different models & so it is not firmware which is loaded into the GS911

M$ has had issues with some PCs/Notebooks USB in W10 but I did not see any in the latest updates on the test system


JRWooden

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: After upgrade to V2203.5 unit will not stay connected USB to bike
« Reply #4 on: April 21, 2022, 02:57:26 AM »

OK ... so I'm a bit confused....  :o

Support got back to me and said to install the diagnostic software and see if you can connect with that software?
here: https://www.hexgs911.com/gs-911-downloads/

I went to that page to download and I was 99% sure that it was that package that I had used to "upgrade".
I started to download it and the browser say it already existed and asked if I wanted to over-write.

At that point I was 99% convinced this was just a repeat and would not fix my issue ...
but ... I went along ...
I did an overlay install and ... well my problem went away ... so I'm not quite clear WTF was going on....   :o

but it's fixed...  8)