Author Topic: F650GSDakar  (Read 5034 times)

kjhunt

  • Newbie
  • *
  • Posts: 36
  • Karma: +1/-0
F650GSDakar
« on: January 23, 2015, 10:05:18 AM »
Some time back I posted a problem I had with this bike in that it would not start, well it did when I pulled in the clutch, but after awhile it stopped all together. Also I was getting just one click from the starter relay. I just wanted to post what I found was the problem.
First off I found that on the starter relay the two small wires leading into it from the switch I found that one was hardly connected any more as it had frayed away. So I set that to rights, and then looked at the clutch switch. I peeled back the covering to find also much the same the two wires were barely holding on. So I sorted that too, and now every thing works fine again.
Bye. Ken

schuppi

  • Sr. Member
  • ****
  • Posts: 481
  • Karma: +20/-0
Re: F650GSDakar
« Reply #1 on: January 23, 2015, 06:35:05 PM »
Hello Ken,
that's great. Thank you for the reponse. This will help other users.

Have a nice day
Schönen Tag
Wolfgang
                                       talk less, drive more

WayneC

  • Beta testers
  • Hero Member
  • *
  • Posts: 1297
  • Karma: +27/-1
Re: F650GSDakar
« Reply #2 on: January 24, 2015, 01:08:26 AM »
Put a dab of silicone over the connector on the neutral switch as well, grease and oil build up there and give leakage to earth so the neutral light glows dimly
« Last Edit: January 24, 2015, 11:15:12 AM by WayneC »

kjhunt

  • Newbie
  • *
  • Posts: 36
  • Karma: +1/-0
Re: F650GSDakar
« Reply #3 on: January 24, 2015, 09:23:41 AM »
OK will do and thanks for that advice there Wayne.