Author Topic: No Service Funktion  (Read 3150 times)

Walterco

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
No Service Funktion
« on: January 26, 2024, 07:17:24 PM »
Hello,

I can no longer use or apply service functions on my GS-911. I always get the message that the service function is not currently available. By functions I mean controlling components to check the function. I can do that before last update.

Greetings Matthias

Rick448

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: No Service Funktion
« Reply #1 on: January 26, 2024, 10:29:45 PM »
Is this on a WiFi model? I assume you are not in D2D mode which does not allow that?

Walterco

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: No Service Funktion
« Reply #2 on: January 27, 2024, 01:41:20 PM »
no, it is connected to the PC with the cable.

Walterco

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: No Service Funktion
« Reply #3 on: January 27, 2024, 01:52:29 PM »
The following problem exists.See appendix.The check engine light is on.Maybe someone has an idea

Fehlercodewert 0x3A13D6
FehlercodeBeschreibung
Fahrwertgeber, Adaption nicht abgeschlossen
Derzeit aktiv JA
Warnleuchte (MIL) JA
Häufigkeit 1
Verlernzähler 0
Fehlercodehistorie -
Datensatznummer 1
Kilometerzähler
70076.0
km
Zeit (abs.) 1312
SAE-Code 0
Zustand NVRAM 0
Zustand NVRAM 0
Bedingung Initialisierung aller Adaptionswerte aufgrund ungültiger NVRAM Daten
0
Status 0

Fehlercodewert 0x3A1183
FehlercodeBeschreibung
Getriebeschaltwalzenpotentiometer, unvollständige Gangadaption bei
freigeschaltetem Schaltassistent
Derzeit aktiv JA
Warnleuchte (MIL) NEIN
Häufigkeit 1
Verlernzähler 0
Fehlercodehistorie -
Datensatznummer 1
Kilometerzähler 70076.0 km
Zeit (abs.) 1312
SAE-Code 0
ADC-Spannung Schalthebelsensor Kanal 1 2.65 V
ADC-Spannung Schalthebelsensor Kanal 2 1.31 V
Spannungswert von Getriebeschaltwalze 0.71 V
Winkel Schalthebelsensor in Neutralstellung adaptiert 199.51

GS Jim

  • Full Member
  • ***
  • Posts: 234
  • Karma: +10/-0
Re: No Service Funktion
« Reply #4 on: January 27, 2024, 07:00:18 PM »
The first fault code reads out like this:

The DME detects an incomplete adaptation of the throttle grip sensor.
"Reset throttle twistgrip sensor adaptation values".
Engine warning light on (as long as the fault is currently present).

second code is:

The DME detects an incomplete gear adaptation when the shift assistant is activated.
Not all gears were adapted with activated shift assistant.
Service Plan Adapt all gears.
If this is not possible, you may need to check the transmission shift control potentiometer.
Engine warning lamp off.

So it looks like you need to reset your twistgrip and shift assist, I've done both with the GS911. Its not hard, just follow the instructions that it gives and if the codes are still there then remove them, ride, then rescan and see if they come back.

Walterco

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: No Service Funktion
« Reply #5 on: January 28, 2024, 06:50:17 PM »
Hello Jim, today I downloaded and installed the diagnostic software again. Now the service function works. Then, as you wrote, I recalibrated the throttle grip and the gearbox. There are no longer any errors. Thanks for the tip.
How can this happen? I had the motorcycle delivered to my home fresh from the workshop.