Author Topic: Changed tires - ABS stopped working  (Read 3932 times)

KRTW

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Changed tires - ABS stopped working
« on: August 19, 2023, 05:51:15 PM »
Changed tires - ABS stopped working - changing the front sensor did not fix this. Hitting the road soon, on a tour, so will check in later. Can't post with an attachment so going to write down what the scan says:

59700 and 59701
CAN bus: No communication with engine (BMS-K) control unit
Currently present: NO

That's it. What might be causing this? Not the sensor, as the front is brand new.

Thanks.

Just in case, this is a F800gs 2013 - again this began after changing the front and back tires.

GS Jim

  • Full Member
  • ***
  • Posts: 234
  • Karma: +10/-0
Re: Changed tires - ABS stopped working
« Reply #1 on: August 19, 2023, 09:11:41 PM »
Try clearing the fault and see if it returns.

KRTW

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Changed tires - ABS stopped working
« Reply #2 on: August 22, 2023, 06:59:26 PM »
Hi. Latest update. I got all the GS911 software updated, and ran the scan. Same faults came up. So I cleared all faults, rescanned and the issues appeared to be gone. ABS passed. Only thing is the problem still exists. The ABS light and above it, a triangle with a circle around it are still flashing and the speedometer does not work. Ok. Now what? I totally removed power disconnecting the battery, like a hard reboot. It did nothing. So, ECU reader tells me everything is good - but its not.

Where do I go next?

GS Jim

  • Full Member
  • ***
  • Posts: 234
  • Karma: +10/-0
Re: Changed tires - ABS stopped working
« Reply #3 on: August 22, 2023, 09:30:20 PM »
Did you ride after clearing faults and rescan?
Get both wheels off the ground and give them a spin while using live view and see if the wheel sensors are being seen. Make sure your wheels have been reinstalled with the collars correctly and the ring look like the are a appropriate distance from the sensors like maybe a mm or 2. Don't know the correct distance off hand.

KRTW

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Changed tires - ABS stopped working
« Reply #4 on: August 23, 2023, 04:43:04 AM »
Problem fixed. The speedo runs off the rear sensor, not the front. Once somebody told me that I took a look at the rear sensor. It had vibrated loose and was too far away. A 1 minute fix, after wasting so much time. I hope I get better at this stuff.

Borgia

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +1/-0
Re: Changed tires - ABS stopped working
« Reply #5 on: August 23, 2023, 06:36:19 AM »
Problem fixed. The speedo runs off the rear sensor, not the front. Once somebody told me that I took a look at the rear sensor. It had vibrated loose and was too far away. A 1 minute fix, after wasting so much time. I hope I get better at this stuff.

Glad that I could help.
Hey BMW: No service manual = no new bike.