Author Topic: #17910/ Brake fluid low  (Read 352 times)

Bill Kenney

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
#17910/ Brake fluid low
« on: June 18, 2017, 01:26:22 AM »
Hi ,
Bike is a 2004 R1150GS Adv  117k miles (Whizzy brakes)
Performed a major service and after flushing the brake fluid, both circuits, I received the above code 17910.

I opened up the caps on top of the modulator and fluid is to the top of screen, since then I have added some fluid, reflushed the front and rear circuits to no avail.

Everything appears to be at the prescribed levels.
Going to give it a break for tonight but wonder if anyone else has had this problem. I have performed the procedure many times in the past and can't see where I have done anything different.

Thanks
Bill Kenney
Foster, RI

Jughead

  • Beta testers
  • Sr. Member
  • *
  • Posts: 384
  • Karma: +32/-2
    • Dual Sport Motorcycle Clinic
Re: #17910/ Brake fluid low
« Reply #1 on: June 19, 2017, 07:00:23 AM »
Might be that one of the floats on the modulator has got stuck in the lowered position, you have a badly seated plug or broken wiring leading to the float sensor.

You can first try to just rap the black cover with the handle of a screwdriver to dislodge the float if it is stuck.  Just a gentle rap, and do not use a hammer on it.  It is plastic and will break.

If that doesn't work, and you are sure the wiring and plugs are secure, then you would need to remove the float cover and inspect.  Will post a pic of what you are dealing with.

« Last Edit: June 19, 2017, 07:04:19 AM by Jughead »

Bill Kenney

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: #17910/ Brake fluid low
« Reply #2 on: June 19, 2017, 05:15:28 PM »
Thanks for the reply
I removed the plugs from the "fluid level floats" and tested continuity . I am getting approx. 0.50 ohms on both. I don't think I would get both floats to stick at the same time so don't know if that is the answer to my problem

I have also tried a good rap or two on the float housing to no avail.

Any other suggestions?
Dealer is closed today so I am still looking for solutions.